CVE-2014-0142

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

QEMU, possibly before 2.0.0, allows local users to cause a denial of service (divide-by-zero error and crash) via a zero value in the (1) tracks field to the seek_to_sector function in block/parallels.c or (2) extent_size field in the bochs function in block/bochs.c.

References

http://git.qemu.org/?p=qemu.git;a=commitdiff;h=8e53abbc20d08ae3ec30c2054e1161314ad9501d

http://git.qemu.org/?p=qemu.git;a=commitdiff;h=9302e863aa8baa5d932fc078967050c055fa1a7f

http://rhn.redhat.com/errata/RHSA-2014-0420.html

http://rhn.redhat.com/errata/RHSA-2014-0421.html

http://www.debian.org/security/2014/dsa-3044

https://bugzilla.redhat.com/show_bug.cgi?id=1078201

Details

Source: MITRE

Published: 2017-08-10

Updated: 2017-11-04

Type: CWE-369

Risk Information

CVSS v2

Base Score: 2.1

Vector: AV:L/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 3.9

Severity: LOW

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:qemu:qemu:*:rc3:*:*:*:*:*:* versions up to 2.0.0 (inclusive)

Tenable Plugins

View all (14 total)

IDNameProductFamilySeverity
81944Mandriva Linux Security Advisory : qemu (MDVSA-2015:061)NessusMandriva Local Security Checks
high
79407Mandriva Linux Security Advisory : qemu (MDVSA-2014:220)NessusMandriva Local Security Checks
high
79029RHEL 6 : rhev-hypervisor6 3.4.0 (RHSA-2014:0674)NessusRed Hat Local Security Checks
high
79015RHEL 6 : qemu-kvm-rhev (RHSA-2014:0421)NessusRed Hat Local Security Checks
high
78046Debian DSA-3045-1 : qemu - security updateNessusDebian Local Security Checks
high
78045Debian DSA-3044-1 : qemu-kvm - security updateNessusDebian Local Security Checks
high
77570Ubuntu 10.04 LTS / 12.04 LTS / 14.04 LTS : qemu, qemu-kvm vulnerabilities (USN-2342-1)NessusUbuntu Local Security Checks
high
77461GLSA-201408-17 : QEMU: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
73939SuSE 11.3 Security Update : kvm (SAT Patch Number 9142)NessusSuSE Local Security Checks
high
73818Fedora 20 : qemu-1.6.2-4.fc20 (2014-5825)NessusFedora Local Security Checks
high
73664Scientific Linux Security Update : qemu-kvm on SL6.x i386/x86_64 (20140422)NessusScientific Linux Local Security Checks
high
73663RHEL 6 : qemu-kvm (RHSA-2014:0420)NessusRed Hat Local Security Checks
high
73662Oracle Linux 6 : qemu-kvm (ELSA-2014-0420)NessusOracle Linux Local Security Checks
high
73656CentOS 6 : qemu-kvm (CESA-2014:0420)NessusCentOS Local Security Checks
high