CVE-2013-7339

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The rds_ib_laddr_check function in net/rds/ib.c in the Linux kernel before 3.12.8 allows local users to cause a denial of service (NULL pointer dereference and system crash) or possibly have unspecified other impact via a bind system call for an RDS socket on a system that lacks RDS transports.

References

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=c2349758acf1874e4c2b93fe41d072336f1a31d0

http://secunia.com/advisories/59386

http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.12.8

http://www.openwall.com/lists/oss-security/2014/03/20/14

http://www.securityfocus.com/bid/66351

https://bugzilla.redhat.com/show_bug.cgi?id=1079214

https://github.com/torvalds/linux/commit/c2349758acf1874e4c2b93fe41d072336f1a31d0

Details

Source: MITRE

Published: 2014-03-24

Updated: 2020-08-28

Type: CWE-476

Risk Information

CVSS v2

Base Score: 4.7

Vector: AV:L/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 3.4

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*

Tenable Plugins

View all (18 total)

IDNameProductFamilySeverity
124991EulerOS Virtualization for ARM 64 3.0.1.0 : kernel (EulerOS-SA-2019-1538)NessusHuawei Local Security Checks
critical
124801EulerOS Virtualization 3.0.1.0 : kernel (EulerOS-SA-2019-1477)NessusHuawei Local Security Checks
medium
79043RHEL 6 : kernel (RHSA-2014:1101)NessusRed Hat Local Security Checks
high
76948CentOS 6 : kernel (CESA-2014:0981)NessusCentOS Local Security Checks
high
76908RHEL 6 : kernel (RHSA-2014:0981)NessusRed Hat Local Security Checks
high
76888Oracle Linux 6 : kernel (ELSA-2014-0981)NessusOracle Linux Local Security Checks
high
76674RHEL 6 : MRG (RHSA-2014:0439)NessusRed Hat Local Security Checks
critical
76557SuSE 11.3 Security Update : Linux kernel (SAT Patch Numbers 9488 / 9491 / 9493)NessusSuSE Local Security Checks
critical
76342openSUSE Security Update : kernel (openSUSE-SU-2014:0856-1)NessusSuSE Local Security Checks
high
76228openSUSE Security Update : kernel (openSUSE-SU-2014:0840-1)NessusSuSE Local Security Checks
high
74505Oracle Linux 5 : kernel (ELSA-2014-0740-1)NessusOracle Linux Local Security Checks
high
74489Scientific Linux Security Update : kernel on SL5.x i386/x86_64 (20140610)NessusScientific Linux Local Security Checks
high
74482Oracle Linux 5 : kernel (ELSA-2014-0740)NessusOracle Linux Local Security Checks
high
74471CentOS 5 : kernel (CESA-2014:0740)NessusCentOS Local Security Checks
high
74458RHEL 5 : kernel (RHSA-2014:0740)NessusRed Hat Local Security Checks
high
74183Ubuntu 10.04 LTS : linux-ec2 vulnerabilities (USN-2220-1)NessusUbuntu Local Security Checks
high
74182Ubuntu 10.04 LTS : linux vulnerabilities (USN-2219-1)NessusUbuntu Local Security Checks
high
73713Debian DSA-2906-1 : linux-2.6 - privilege escalation/denial of service/information leakNessusDebian Local Security Checks
critical