CVE-2013-6456

MEDIUM

Description

The LXC driver (lxc/lxc_driver.c) in libvirt 1.0.1 through 1.2.1 allows local users to (1) delete arbitrary host devices via the virDomainDeviceDettach API and a symlink attack on /dev in the container; (2) create arbitrary nodes (mknod) via the virDomainDeviceAttach API and a symlink attack on /dev in the container; and cause a denial of service (shutdown or reboot host OS) via the (3) virDomainShutdown or (4) virDomainReboot API and a symlink attack on /dev/initctl in the container, related to "paths under /proc/$PID/root" and the virInitctlSetRunLevel function.

References

http://libvirt.org/git/?p=libvirt.git;a=commit;h=5fc590ad9f4

http://libvirt.org/news.html

http://lists.fedoraproject.org/pipermail/package-announce/2014-February/129199.html

http://lists.opensuse.org/opensuse-updates/2014-05/msg00004.html

http://secunia.com/advisories/56187

http://secunia.com/advisories/56215

http://secunia.com/advisories/60895

http://security.gentoo.org/glsa/glsa-201412-04.xml

http://security.libvirt.org/2013/0018.html

http://www.securityfocus.com/bid/65743

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732394

https://bugzilla.redhat.com/show_bug.cgi?id=1045643

Details

Source: MITRE

Published: 2014-04-15

Updated: 2015-01-03

Type: CWE-59

Risk Information

CVSS v2.0

Base Score: 5.8

Vector: AV:A/AC:M/Au:S/C:N/I:P/A:C

Impact Score: 7.8

Exploitability Score: 4.4

Severity: MEDIUM

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
82368Mandriva Linux Security Advisory : libvirt (MDVSA-2015:115)NessusMandriva Local Security Checks
medium
79814GLSA-201412-04 : libvirt: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
75338openSUSE Security Update : libvirt (openSUSE-SU-2014:0593-1)NessusSuSE Local Security Checks
medium
74507SuSE 11.3 Security Update : libvirt (SAT Patch Number 9203)NessusSuSE Local Security Checks
medium
74075Mandriva Linux Security Advisory : libvirt (MDVSA-2014:097)NessusMandriva Local Security Checks
medium
73940Ubuntu 13.10 : libvirt vulnerabilities (USN-2209-1)NessusUbuntu Local Security Checks
medium
72753Fedora 20 : libvirt-1.1.3.4-1.fc20 (2014-2864)NessusFedora Local Security Checks
medium