CVE-2013-4935

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The dissect_per_length_determinant function in epan/dissectors/packet-per.c in the ASN.1 PER dissector in Wireshark 1.8.x before 1.8.9 and 1.10.x before 1.10.1 does not initialize a length field in certain abnormal situations, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

References

http://anonsvn.wireshark.org/viewvc/trunk/epan/dissectors/packet-per.c?r1=49985&r2=49984&pathrev=49985

http://anonsvn.wireshark.org/viewvc?view=revision&revision=49985

http://lists.opensuse.org/opensuse-updates/2013-08/msg00004.html

http://lists.opensuse.org/opensuse-updates/2013-08/msg00009.html

http://rhn.redhat.com/errata/RHSA-2014-0341.html

http://secunia.com/advisories/54178

http://secunia.com/advisories/54296

http://secunia.com/advisories/54371

http://secunia.com/advisories/54425

http://www.debian.org/security/2013/dsa-2734

http://www.gentoo.org/security/en/glsa/glsa-201308-05.xml

http://www.wireshark.org/docs/relnotes/wireshark-1.10.1.html

http://www.wireshark.org/docs/relnotes/wireshark-1.8.9.html

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8722

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A17417

https://www.wireshark.org/security/wnpa-sec-2013-52.html

Details

Source: MITRE

Published: 2013-07-30

Updated: 2017-09-19

Type: CWE-189

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
80808Oracle Solaris Third-Party Patch Update : wireshark (multiple_vulnerabilities_in_wireshark6)NessusSolaris Local Security Checks
high
79601F5 Networks BIG-IP : Multiple Wireshark vulnerabilities (K15868)NessusF5 Networks Local Security Checks
high
79162CentOS 6 : wireshark (CESA-2013:1569)NessusCentOS Local Security Checks
high
75104openSUSE Security Update : wireshark (openSUSE-SU-2013:1295-1)NessusSuSE Local Security Checks
high
73285Scientific Linux Security Update : wireshark on SL5.x i386/x86_64 (20140331)NessusScientific Linux Local Security Checks
high
73281RHEL 5 : wireshark (RHSA-2014:0341)NessusRed Hat Local Security Checks
high
73279Oracle Linux 5 : wireshark (ELSA-2014-0341)NessusOracle Linux Local Security Checks
high
73276CentOS 5 : wireshark (CESA-2014:0341)NessusCentOS Local Security Checks
high
71543Fedora 18 : wireshark-1.10.2-4.fc18 (2013-17635)NessusFedora Local Security Checks
high
71301Scientific Linux Security Update : wireshark on SL6.x i386/x86_64 (20131121)NessusScientific Linux Local Security Checks
high
71268Amazon Linux AMI : wireshark (ALAS-2013-251)NessusAmazon Linux Local Security Checks
high
71105Oracle Linux 6 : wireshark (ELSA-2013-1569)NessusOracle Linux Local Security Checks
high
71005RHEL 6 : wireshark (RHSA-2013:1569)NessusRed Hat Local Security Checks
high
70280Fedora 20 : wireshark-1.10.2-7.fc20 (2013-17627)NessusFedora Local Security Checks
high
70181Fedora 19 : wireshark-1.10.2-6.fc19 (2013-17661)NessusFedora Local Security Checks
high
69894SuSE 11.2 / 11.3 Security Update : wireshark (SAT Patch Numbers 8318 / 8319)NessusSuSE Local Security Checks
high
69893SuSE 11.2 / 11.3 Security Update : wireshark (SAT Patch Numbers 8318 / 8319)NessusSuSE Local Security Checks
high
69500GLSA-201308-05 : Wireshark: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
69228Debian DSA-2734-1 : wireshark - several vulnerabilitiesNessusDebian Local Security Checks
medium
69155Mandriva Linux Security Advisory : wireshark (MDVSA-2013:204)NessusMandriva Local Security Checks
high
69105Wireshark 1.10.x < 1.10.1 Multiple VulnerabilitiesNessusWindows
high
69104Wireshark 1.8.x < 1.8.9 Multiple VulnerabilitiesNessusWindows
high