CVE-2013-4363

MEDIUM

Description

Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.

References

http://blog.rubygems.org/2013/09/24/CVE-2013-4363.html

http://www.openwall.com/lists/oss-security/2013/09/14/3

http://www.openwall.com/lists/oss-security/2013/09/18/8

http://www.openwall.com/lists/oss-security/2013/09/20/1

https://puppet.com/security/cve/cve-2013-4363

Details

Source: MITRE

Published: 2013-10-17

Updated: 2017-12-09

Type: CWE-310

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: (AV:N/AC:M/Au:N/C:N/I:N/A:P)

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM