CVE-2013-4282

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack-based buffer overflow in the reds_handle_ticket function in server/reds.c in SPICE 0.12.0 allows remote attackers to cause a denial of service (crash) via a long password in a SPICE ticket.

References

http://cgit.freedesktop.org/spice/spice/commit/?id=8af619009660b24e0b41ad26b30289eea288fcc2

http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00008.html

http://rhn.redhat.com/errata/RHSA-2013-1460.html

http://rhn.redhat.com/errata/RHSA-2013-1473.html

http://rhn.redhat.com/errata/RHSA-2013-1474.html

http://www.debian.org/security/2014/dsa-2839

http://www.securityfocus.com/bid/63408

http://www.ubuntu.com/usn/USN-2027-1

Details

Source: MITRE

Published: 2013-11-02

Updated: 2019-04-22

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
86392openSUSE Security Update : spice (openSUSE-2015-657)NessusSuSE Local Security Checks
high
83726SUSE SLED12 / SLES12 Security Update : spice (SUSE-SU-2015:0884-1)NessusSuSE Local Security Checks
medium
78977RHEL 6 : rhev-hypervisor6 (RHSA-2013:1460)NessusRed Hat Local Security Checks
high
72100Mandriva Linux Security Advisory : spice (MDVSA-2014:016)NessusMandriva Local Security Checks
medium
71867Debian DSA-2839-1 : spice - denial of serviceNessusDebian Local Security Checks
medium
70874Ubuntu 13.04 / 13.10 : spice vulnerability (USN-2027-1)NessusUbuntu Local Security Checks
medium
70827Fedora 20 : spice-0.12.4-3.fc20 (2013-20310)NessusFedora Local Security Checks
medium
70788Fedora 18 : spice-0.12.4-3.fc18 (2013-20360)NessusFedora Local Security Checks
medium
70787Fedora 19 : spice-0.12.4-3.fc19 (2013-20340)NessusFedora Local Security Checks
medium
70707Scientific Linux Security Update : spice-server on SL6.x x86_64 (20131029)NessusScientific Linux Local Security Checks
medium
70706Scientific Linux Security Update : qspice on SL5.x x86_64 (20131029)NessusScientific Linux Local Security Checks
medium
70695RHEL 5 : qspice (RHSA-2013:1474)NessusRed Hat Local Security Checks
medium
70694RHEL 6 : spice-server (RHSA-2013:1473)NessusRed Hat Local Security Checks
medium
70691Oracle Linux 5 : qspice (ELSA-2013-1474)NessusOracle Linux Local Security Checks
medium
70690Oracle Linux 6 : spice-server (ELSA-2013-1473)NessusOracle Linux Local Security Checks
medium
70686CentOS 5 : qspice (CESA-2013:1474)NessusCentOS Local Security Checks
medium
70685CentOS 6 : spice-server (CESA-2013:1473)NessusCentOS Local Security Checks
medium