CVE-2013-1792

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Race condition in the install_user_keyrings function in security/keys/process_keys.c in the Linux kernel before 3.8.3 allows local users to cause a denial of service (NULL pointer dereference and system crash) via crafted keyctl system calls that trigger keyring operations in simultaneous threads.

References

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=0da9dfdd2cd9889201bc6f6f43580c99165cd087

http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00018.html

http://lists.opensuse.org/opensuse-security-announce/2014-02/msg00002.html

http://rhn.redhat.com/errata/RHSA-2013-0744.html

http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.8.3

http://www.mandriva.com/security/advisories?name=MDVSA-2013:176

http://www.openwall.com/lists/oss-security/2013/03/07/1

http://www.ubuntu.com/usn/USN-1787-1

http://www.ubuntu.com/usn/USN-1788-1

http://www.ubuntu.com/usn/USN-1792-1

http://www.ubuntu.com/usn/USN-1793-1

http://www.ubuntu.com/usn/USN-1794-1

http://www.ubuntu.com/usn/USN-1795-1

http://www.ubuntu.com/usn/USN-1796-1

http://www.ubuntu.com/usn/USN-1797-1

http://www.ubuntu.com/usn/USN-1798-1

https://bugzilla.redhat.com/show_bug.cgi?id=916646

https://github.com/torvalds/linux/commit/0da9dfdd2cd9889201bc6f6f43580c99165cd087

Details

Source: MITRE

Published: 2013-03-22

Updated: 2014-03-06

Type: CWE-362

Risk Information

CVSS v2

Base Score: 4.7

Vector: AV:L/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 3.4

Severity: MEDIUM

Tenable Plugins

View all (25 total)

IDNameProductFamilySeverity
83611SUSE SLES11 Security Update : kernel (SUSE-SU-2014:0287-1)NessusSuSE Local Security Checks
high
76660RHEL 6 : MRG (RHSA-2013:0829)NessusRed Hat Local Security Checks
high
75251openSUSE Security Update : kernel (openSUSE-SU-2014:0204-1)NessusSuSE Local Security Checks
high
68856Oracle Linux 5 / 6 : Unbreakable Enterprise kernel Security (ELSA-2013-2534)NessusOracle Linux Local Security Checks
high
68855Oracle Linux 5 / 6 : Unbreakable Enterprise kernel Security (ELSA-2013-2525)NessusOracle Linux Local Security Checks
high
68853Oracle Linux 5 / 6 : Unbreakable Enterprise kernel (ELSA-2013-2523)NessusOracle Linux Local Security Checks
medium
68852Oracle Linux 5 / 6 : Unbreakable Enterprise kernel (ELSA-2013-2520)NessusOracle Linux Local Security Checks
medium
68851Oracle Linux 5 / 6 : Unbreakable Enterprise kernel Security (ELSA-2013-2519)NessusOracle Linux Local Security Checks
medium
68807Oracle Linux 6 : kernel (ELSA-2013-0744)NessusOracle Linux Local Security Checks
high
66975Mandriva Linux Security Advisory : kernel (MDVSA-2013:176)NessusMandriva Local Security Checks
high
66431Debian DSA-2668-1 : linux-2.6 - privilege escalation/denial of service/information leakNessusDebian Local Security Checks
medium
66344SuSE 11.2 Security Update : Linux kernel (SAT Patch Numbers 7667 / 7669 / 7675)NessusSuSE Local Security Checks
high
66214Scientific Linux Security Update : kernel on SL6.x i386/x86_64 (20130423)NessusScientific Linux Local Security Checks
high
66204CentOS 6 : kernel (CESA-2013:0744)NessusCentOS Local Security Checks
high
66192RHEL 6 : kernel (RHSA-2013:0744)NessusRed Hat Local Security Checks
high
65872Ubuntu 10.04 LTS : linux-ec2 vulnerabilities (USN-1798-1)NessusUbuntu Local Security Checks
medium
65871Ubuntu 12.10 : linux vulnerabilities (USN-1796-1)NessusUbuntu Local Security Checks
medium
65870Ubuntu 12.04 LTS : linux-lts-quantal vulnerabilities (USN-1795-1)NessusUbuntu Local Security Checks
medium
65869Ubuntu 12.04 LTS : linux vulnerabilities (USN-1793-1)NessusUbuntu Local Security Checks
medium
65868Ubuntu 10.04 LTS : linux vulnerabilities (USN-1792-1)NessusUbuntu Local Security Checks
medium
65800Ubuntu 10.04 LTS : linux-lts-backport-oneiric vulnerabilities (USN-1788-1)NessusUbuntu Local Security Checks
medium
65788Ubuntu 11.10 : linux vulnerabilities (USN-1787-1)NessusUbuntu Local Security Checks
medium
65650Fedora 17 : kernel-3.8.3-103.fc17 (2013-3909)NessusFedora Local Security Checks
high
65183Fedora 18 : kernel-3.8.2-206.fc18 (2013-3630)NessusFedora Local Security Checks
medium
801540CentOS RHSA-2013-0744 Security CheckLog Correlation EngineGeneric
high