CVE-2013-1664

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The XML libraries for Python 3.4, 3.3, 3.2, 3.1, 2.7, and 2.6, as used in OpenStack Keystone Essex, Folsom, and Grizzly; Compute (Nova) Essex and Folsom; Cinder Folsom; Django; and possibly other products allow remote attackers to cause a denial of service (resource consumption and crash) via an XML Entity Expansion (XEE) attack.

References

http://blog.python.org/2013/02/announcing-defusedxml-fixes-for-xml.html

http://bugs.python.org/issue17239

http://lists.openstack.org/pipermail/openstack-announce/2013-February/000078.html

http://rhn.redhat.com/errata/RHSA-2013-0657.html

http://rhn.redhat.com/errata/RHSA-2013-0658.html

http://rhn.redhat.com/errata/RHSA-2013-0670.html

http://ubuntu.com/usn/usn-1757-1

http://www.openwall.com/lists/oss-security/2013/02/19/2

http://www.openwall.com/lists/oss-security/2013/02/19/4

https://bugs.launchpad.net/nova/+bug/1100282

Details

Source: MITRE

Published: 2013-04-03

Updated: 2013-05-15

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
79964GLSA-201412-11 : AMD64 x86 emulation base libraries: Multiple vulnerabilities (Heartbleed)NessusGentoo Local Security Checks
critical
74936openSUSE Security Update : openstack (openSUSE-2013-237)NessusSuSE Local Security Checks
medium
70836GLSA-201311-06 : libxml2: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
65096Ubuntu 10.04 LTS / 11.10 / 12.04 LTS / 12.10 : python-django vulnerabilities (USN-1757-1)NessusUbuntu Local Security Checks
medium
64997Fedora 18 : openstack-keystone-2012.2.3-3.fc18 (2013-2916)NessusFedora Local Security Checks
medium
64873FreeBSD : django -- multiple vulnerabilities (21c59f5e-7cc5-11e2-9c11-080027a5ec9a)NessusFreeBSD Local Security Checks
medium
64800Ubuntu 11.10 / 12.04 LTS / 12.10 : nova vulnerability (USN-1734-1)NessusUbuntu Local Security Checks
medium
64783Ubuntu 12.10 : cinder vulnerability (USN-1731-1)NessusUbuntu Local Security Checks
medium
64782Ubuntu 12.04 LTS / 12.10 : keystone vulnerabilities (USN-1730-1)NessusUbuntu Local Security Checks
medium