CVE-2013-0249

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack-based buffer overflow in the Curl_sasl_create_digest_md5_message function in lib/curl_sasl.c in curl and libcurl 7.26.0 through 7.28.1, when negotiating SASL DIGEST-MD5 authentication, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long string in the realm parameter in a (1) POP3, (2) SMTP or (3) IMAP message.

References

http://blog.volema.com/curl-rce.html

http://curl.haxx.se/docs/adv_20130206.html

http://lists.apple.com/archives/security-announce/2013/Oct/msg00004.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-February/099140.html

http://nakedsecurity.sophos.com/2013/02/10/anatomy-of-a-vulnerability-curl-web-download-toolkit-holed-by-authentication-bug/

http://packetstormsecurity.com/files/120147/cURL-Buffer-Overflow.html

http://packetstormsecurity.com/files/120170/Slackware-Security-Advisory-curl-Updates.html

http://www.exploit-db.com/exploits/24487

http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html

http://www.osvdb.org/89988

http://www.securityfocus.com/bid/57842

http://www.securitytracker.com/id/1028093

http://www.ubuntu.com/usn/USN-1721-1

Details

Source: MITRE

Published: 2013-03-08

Updated: 2016-12-08

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
72053GLSA-201401-14 : cURL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
70561Mac OS X 10.x < 10.9 Multiple Vulnerabilities (BEAST)NessusMacOS X Local Security Checks
high
801393cURL/libcURL 'Curl_sasl_create_digest_md5_message()' Stack Buffer Overflow VulnerabilityLog Correlation EngineWeb Clients
medium
6901cURL/libcURL 'Curl_sasl_create_digest_md5_message()' Stack Buffer OverflowNessus Network MonitorWeb Clients
high
64869Fedora 18 : curl-7.27.0-6.fc18 (2013-2098)NessusFedora Local Security Checks
high
64619Ubuntu 12.10 : curl vulnerability (USN-1721-1)NessusUbuntu Local Security Checks
high
64491Slackware 14.0 / current : curl (SSA:2013-038-01)NessusSlackware Local Security Checks
high