CVE-2012-6032

medium

Description

Multiple integer overflows in the (1) tmh_copy_from_client and (2) tmh_copy_to_client functions in the Transcendent Memory (TMEM) in Xen 4.0, 4.1, and 4.2 allow local guest OS users to cause a denial of service (memory corruption and host crash) via unspecified vectors. NOTE: this issue was originally published as part of CVE-2012-3497, which was too general; CVE-2012-3497 has been SPLIT into this ID and others.

References

http://lists.xen.org/archives/html/xen-announce/2012-09/msg00006.html

http://osvdb.org/85199

http://secunia.com/advisories/50472

http://secunia.com/advisories/55082

http://security.gentoo.org/glsa/glsa-201309-24.xml

http://wiki.xen.org/wiki/Security_Announcements#XSA-15_multiple_TMEM_hypercall_vulnerabilities

http://www.openwall.com/lists/oss-security/2012/09/05/8

http://www.securityfocus.com/bid/55410

http://www.securitytracker.com/id?1027482

https://exchange.xforce.ibmcloud.com/vulnerabilities/78268

https://security.gentoo.org/glsa/201604-03

Details

Source: MITRE

Published: 2012-11-23

Updated: 2017-08-29

Type: CWE-189

Risk Information

CVSS v2

Base Score: 4.9

Vector: AV:L/AC:L/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 3.9

Severity: MEDIUM