CVE-2012-3481

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Integer overflow in the ReadImage function in plug-ins/common/file-gif-load.c in the GIF image format plug-in in GIMP 2.8.x and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted height and len properties in a GIF image file, which triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

References

http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00023.html

http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00000.html

http://lists.opensuse.org/opensuse-updates/2012-09/msg00043.html

http://rhn.redhat.com/errata/RHSA-2012-1180.html

http://rhn.redhat.com/errata/RHSA-2012-1181.html

http://secunia.com/advisories/50296

http://www.mandriva.com/security/advisories?name=MDVSA-2012:142

http://www.mandriva.com/security/advisories?name=MDVSA-2013:082

http://www.openwall.com/lists/oss-security/2012/08/20/8

http://www.securityfocus.com/bid/55101

http://www.securitytracker.com/id?1027411

http://www.ubuntu.com/usn/USN-1559-1

https://bugzilla.novell.com/show_bug.cgi?id=776572

https://bugzilla.redhat.com/show_bug.cgi?id=847303

Details

Source: MITRE

Published: 2012-08-25

Updated: 2013-12-05

Type: CWE-189

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
80622Oracle Solaris Third-Party Patch Update : gimp (multiple_vulnerabilities_in_gimp)NessusSolaris Local Security Checks
medium
74745openSUSE Security Update : gimp (openSUSE-SU-2012:1131-1)NessusSuSE Local Security Checks
high
74735openSUSE Security Update : gimp (openSUSE-SU-2012:1080-1)NessusSuSE Local Security Checks
high
70835GLSA-201311-05 : GIMP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
68601Oracle Linux 5 : gimp (ELSA-2012-1181)NessusOracle Linux Local Security Checks
high
68600Oracle Linux 6 : gimp (ELSA-2012-1180)NessusOracle Linux Local Security Checks
medium
66096Mandriva Linux Security Advisory : gimp (MDVSA-2013:082)NessusMandriva Local Security Checks
high
64149SuSE 11.1 Security Update : gimp (SAT Patch Number 6712)NessusSuSE Local Security Checks
medium
62135Fedora 18 : gimp-2.8.2-1.fc18 (2012-12293)NessusFedora Local Security Checks
medium
62037Ubuntu 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : gimp vulnerabilities (USN-1559-1)NessusUbuntu Local Security Checks
medium
61987Mandriva Linux Security Advisory : gimp (MDVSA-2012:142)NessusMandriva Local Security Checks
medium
61756Fedora 16 : gimp-2.6.12-2.fc16 (2012-12364)NessusFedora Local Security Checks
medium
61703Fedora 17 : gimp-2.8.2-1.fc17 (2012-12383)NessusFedora Local Security Checks
medium
61680SuSE 10 Security Update : gimp (ZYPP Patch Number 8253)NessusSuSE Local Security Checks
medium
61606Scientific Linux Security Update : gimp on SL6.x i386/x86_64 (20120820)NessusScientific Linux Local Security Checks
medium
61605Scientific Linux Security Update : gimp on SL5.x i386/x86_64 (20120820)NessusScientific Linux Local Security Checks
high
61604RHEL 5 : gimp (RHSA-2012:1181)NessusRed Hat Local Security Checks
high
61603RHEL 6 : gimp (RHSA-2012:1180)NessusRed Hat Local Security Checks
medium
61600CentOS 5 : gimp (CESA-2012:1181)NessusCentOS Local Security Checks
high
61599CentOS 6 : gimp (CESA-2012:1180)NessusCentOS Local Security Checks
medium