CVE-2012-3292

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The GridFTP in Globus Toolkit (GT) before 5.2.2, when certain autoconf macros are defined, does not properly check the return value from the getpwnam_r function, which might allow remote attackers to gain privileges by logging in with a user that does not exist, which causes GridFTP to run as the last user in the password file.

References

http://jira.globus.org/browse/GT-195

http://lists.fedoraproject.org/pipermail/package-announce/2012-June/081787.html

http://lists.fedoraproject.org/pipermail/package-announce/2012-June/081791.html

http://lists.fedoraproject.org/pipermail/package-announce/2012-June/081797.html

http://www.debian.org/security/2012/dsa-2523

Details

Source: MITRE

Published: 2012-06-07

Updated: 2012-09-07

Type: CWE-264

Risk Information

CVSS v2

Base Score: 7.6

Vector: AV:N/AC:H/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 4.9

Severity: HIGH

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
61439Debian DSA-2523-1 : globus-gridftp-server - programming errorNessusDebian Local Security Checks
high
59734Globus Toolkit GridFTP Server < 3.42 / 6.11 'getpwnam_r()' Authentication Bypass VulnerabilityNessusFTP
high
59351Fedora 15 : globus-gridftp-server-6.10-2.fc15 / globus-gridftp-server-control-2.5-2.fc15 (2012-8488)NessusFedora Local Security Checks
high
59348Fedora 16 : globus-gridftp-server-6.10-2.fc16 / globus-gridftp-server-control-2.5-2.fc16 (2012-8461)NessusFedora Local Security Checks
high
59347Fedora 17 : globus-gridftp-server-6.10-2.fc17 / globus-gridftp-server-control-2.5-2.fc17 (2012-8445)NessusFedora Local Security Checks
high