CVE-2012-2135

medium

Description

The utf-16 decoder in Python 3.1 through 3.3 does not update the aligned_end variable after calling the unicode_decode_call_errorhandler function, which allows remote attackers to obtain sensitive information (process memory) or cause a denial of service (memory corruption and crash) via unspecified vectors.

References

http://bugs.python.org/issue14579

http://www.openwall.com/lists/oss-security/2012/04/25/4

http://www.openwall.com/lists/oss-security/2012/04/25/2

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=670389

http://www.ubuntu.com/usn/USN-1615-1

http://secunia.com/advisories/51089

http://www.ubuntu.com/usn/USN-1616-1

http://secunia.com/advisories/51087

Details

Source: MITRE

Published: 2012-08-14

Updated: 2022-07-28

Risk Information

CVSS v2

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM