CVE-2012-1895

HIGH

Description

The reflection implementation in Microsoft .NET Framework 1.0 SP3, 1.1 SP1, 2.0 SP2, 3.5.1, and 4 does not properly enforce object permissions, which allows remote attackers to execute arbitrary code via (1) a crafted XAML browser application (aka XBAP) or (2) a crafted .NET Framework application, aka "Reflection Bypass Vulnerability."

References

http://secunia.com/advisories/51236

http://www.securitytracker.com/id?1027753

http://www.us-cert.gov/cas/techalerts/TA12-318A.html

https://docs.microsoft.com/en-us/security-updates/securitybulletins/2012/ms12-074

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A15924

Details

Source: MITRE

Published: 2012-11-14

Updated: 2019-02-26

Type: CWE-264

Risk Information

CVSS v2.0

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH