CVE-2012-1013

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The check_1_6_dummy function in lib/kadm5/srv/svr_principal.c in kadmind in MIT Kerberos 5 (aka krb5) 1.8.x, 1.9.x, and 1.10.x before 1.10.2 allows remote authenticated administrators to cause a denial of service (NULL pointer dereference and daemon crash) via a KRB5_KDB_DISALLOW_ALL_TIX create request that lacks a password.

References

http://krbdev.mit.edu/rt/Ticket/Display.html?user=guest&pass=guest&id=7152

http://mailman.mit.edu/pipermail/kerberos-announce/2012q2/000136.html

http://rhn.redhat.com/errata/RHSA-2012-1131.html

http://web.mit.edu/kerberos/krb5-1.10/

http://www.mandriva.com/security/advisories?name=MDVSA-2012:102

http://www.securityfocus.com/bid/53784

https://bugzilla.redhat.com/show_bug.cgi?id=827517

https://github.com/krb5/krb5/commit/c5be6209311d4a8f10fda37d0d3f876c1b33b77b

https://hermes.opensuse.org/messages/15083635

Details

Source: MITRE

Published: 2012-06-07

Updated: 2020-01-21

Risk Information

CVSS v2

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8

Severity: MEDIUM

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
74662openSUSE Security Update : krb5 (openSUSE-SU-2012:0834-1)NessusSuSE Local Security Checks
medium
69604Amazon Linux AMI : krb5 (ALAS-2012-114)NessusAmazon Linux Local Security Checks
high
68589Oracle Linux 6 : krb5 (ELSA-2012-1131)NessusOracle Linux Local Security Checks
high
67093CentOS 6 : krb5 (CESA-2012:1131)NessusCentOS Local Security Checks
high
66056Mandriva Linux Security Advisory : krb5 (MDVSA-2013:042)NessusMandriva Local Security Checks
high
61407Scientific Linux Security Update : krb5 on SL6.x i386/x86_64 (20120731)NessusScientific Linux Local Security Checks
high
61379Ubuntu 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : krb5 vulnerabilities (USN-1520-1)NessusUbuntu Local Security Checks
high
61377RHEL 6 : krb5 (RHSA-2012:1131)NessusRed Hat Local Security Checks
high
59860Mandriva Linux Security Advisory : krb5 (MDVSA-2012:102)NessusMandriva Local Security Checks
medium
59486Fedora 15 : krb5-1.9.3-2.fc15 (2012-8805)NessusFedora Local Security Checks
medium
59485Fedora 16 : krb5-1.9.3-2.fc16 (2012-8803)NessusFedora Local Security Checks
medium
59484Fedora 17 : krb5-1.10-7.fc17 (2012-8784)NessusFedora Local Security Checks
medium