CVE-2011-4966

MEDIUM

Description

modules/rlm_unix/rlm_unix.c in FreeRADIUS before 2.2.0, when unix mode is enabled for user authentication, does not properly check the password expiration in /etc/shadow, which allows remote authenticated users to authenticate using an expired password.

References

http://lists.opensuse.org/opensuse-updates/2013-01/msg00029.html

http://lists.opensuse.org/opensuse-updates/2013-01/msg00079.html

http://rhn.redhat.com/errata/RHBA-2012-0881.html

http://rhn.redhat.com/errata/RHSA-2013-0134.html

https://github.com/alandekok/freeradius-server/commit/1b1ec5ce75e224bd1755650c18ccdaa6dc53e605

Details

Source: MITRE

Published: 2013-03-12

Updated: 2013-03-19

Type: CWE-255

Risk Information

CVSS v2.0

Base Score: 6

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 6.8

Severity: MEDIUM