CVE-2011-4914

MEDIUM

Description

The ROSE protocol implementation in the Linux kernel before 2.6.39 does not verify that certain data-length values are consistent with the amount of data sent, which might allow remote attackers to obtain sensitive information from kernel memory or cause a denial of service (out-of-bounds read) via crafted data to a ROSE socket.

References

http://ftp.osuosl.org/pub/linux/kernel/v2.6/ChangeLog-2.6.39

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=e0bccd315db0c2f919e7fcf9cb60db21d9986f52

http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00020.html

http://www.openwall.com/lists/oss-security/2011/12/28/2

https://bugzilla.redhat.com/show_bug.cgi?id=770777

https://github.com/torvalds/linux/commit/e0bccd315db0c2f919e7fcf9cb60db21d9986f52

Details

Source: MITRE

Published: 2012-06-21

Updated: 2016-08-18

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
83723SUSE SLES10 Security Update : kernel (SUSE-SU-2015:0812-1)NessusSuSE Local Security Checks
high
57583Debian DSA-2389-1 : linux-2.6 - privilege escalation/denial of service/information leakNessusDebian Local Security Checks
medium
56768Ubuntu 10.04 LTS : linux-lts-backport-natty vulnerabilities (USN-1256-1)NessusUbuntu Local Security Checks
critical
56343Ubuntu 10.04 LTS : linux vulnerabilities (USN-1218-1)NessusUbuntu Local Security Checks
high
56305Ubuntu 10.04 LTS : linux-ec2 vulnerabilities (USN-1216-1)NessusUbuntu Local Security Checks
high
56256Ubuntu 11.04 : linux vulnerabilities (USN-1211-1)NessusUbuntu Local Security Checks
high
56207Ubuntu 10.10 : linux-mvl-dove vulnerabilities (USN-1208-1)NessusUbuntu Local Security Checks
high
56191Ubuntu 10.04 LTS : linux-mvl-dove vulnerabilities (USN-1203-1)NessusUbuntu Local Security Checks
high
56189Ubuntu 10.10 : linux vulnerabilities (USN-1201-1)NessusUbuntu Local Security Checks
high
55922Ubuntu 8.04 LTS : linux vulnerabilities (USN-1189-1)NessusUbuntu Local Security Checks
high