CVE-2011-4107

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.

References

http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069625.html

http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069635.html

http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069649.html

http://osvdb.org/76798

http://packetstormsecurity.org/files/view/106511/phpmyadmin-fileread.txt

http://seclists.org/fulldisclosure/2011/Nov/21

http://secunia.com/advisories/46447

http://securityreason.com/securityalert/8533

http://www.debian.org/security/2012/dsa-2391

http://www.mandriva.com/security/advisories?name=MDVSA-2011:198

http://www.openwall.com/lists/oss-security/2011/11/03/3

http://www.openwall.com/lists/oss-security/2011/11/03/5

http://www.phpmyadmin.net/home_page/security/PMASA-2011-17.php

http://www.securityfocus.com/bid/50497

http://www.wooyun.org/bugs/wooyun-2010-03185

https://bugzilla.redhat.com/show_bug.cgi?id=751112

https://exchange.xforce.ibmcloud.com/vulnerabilities/71108

Details

Source: MITRE

Published: 2011-11-17

Updated: 2017-08-29

Type: CWE-200

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
74519openSUSE Security Update : phpMyAdmin (openSUSE-2011-14)NessusSuSE Local Security Checks
medium
59211phpMyAdmin simplexml_load_string() Function Information Disclosure (PMASA-2011-17)NessusCGI abuses
medium
57621Debian DSA-2391-1 : phpmyadmin - several vulnerabilitiesNessusDebian Local Security Checks
medium
57433GLSA-201201-01 : phpMyAdmin: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
56926Fedora 15 : phpMyAdmin-3.4.7.1-1.fc15 (2011-15846)NessusFedora Local Security Checks
medium
56925Fedora 16 : phpMyAdmin-3.4.7.1-1.fc16 (2011-15841)NessusFedora Local Security Checks
medium
56924Fedora 14 : phpMyAdmin-3.4.7.1-1.fc14 (2011-15831)NessusFedora Local Security Checks
medium
56804FreeBSD : phpmyadmin -- Local file inclusion (1f6ee708-0d22-11e1-b5bd-14dae938ec40)NessusFreeBSD Local Security Checks
medium