CVE-2011-1746

MEDIUM

Description

Multiple integer overflows in the (1) agp_allocate_memory and (2) agp_create_user_memory functions in drivers/char/agp/generic.c in the Linux kernel before 2.6.38.5 allow local users to trigger buffer overflows, and consequently cause a denial of service (system crash) or possibly have unspecified other impact, via vectors related to calls that specify a large number of memory pages.

References

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=b522f02184b413955f3bc952e3776ce41edc6355

http://openwall.com/lists/oss-security/2011/04/21/4

http://openwall.com/lists/oss-security/2011/04/22/7

http://rhn.redhat.com/errata/RHSA-2011-0927.html

http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.38.5

http://www.securityfocus.com/bid/47535

https://bugzilla.redhat.com/show_bug.cgi?id=698998

https://lkml.org/lkml/2011/4/14/294

https://lkml.org/lkml/2011/4/19/400

Details

Source: MITRE

Published: 2011-05-09

Updated: 2014-01-14

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 6.9

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.4

Severity: MEDIUM