CVE-2011-1485

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Race condition in the pkexec utility and polkitd daemon in PolicyKit (aka polkit) 0.96 allows local users to gain privileges by executing a setuid program from pkexec, related to the use of the effective user ID instead of the real user ID.

References

http://lists.fedoraproject.org/pipermail/package-announce/2011-April/058752.html

http://lists.fedoraproject.org/pipermail/package-announce/2011-May/059859.html

http://secunia.com/advisories/48817

http://security.gentoo.org/glsa/glsa-201204-06.xml

http://securityreason.com/securityalert/8424

http://www.debian.org/security/2011/dsa-2319

http://www.mandriva.com/security/advisories?name=MDVSA-2011:086

http://www.redhat.com/support/errata/RHSA-2011-0455.html

http://www.ubuntu.com/usn/USN-1117-1

https://bugzilla.redhat.com/show_bug.cgi?id=692922

Details

Source: MITRE

Published: 2011-05-31

Updated: 2012-12-19

Type: CWE-362

Risk Information

CVSS v2

Base Score: 6.9

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.4

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:redhat:policykit:0.96:*:*:*:*:*:*:*

Tenable Plugins

View all (13 total)

IDNameProductFamilySeverity
122573OracleVM 3.3 / 3.4 : polkit (OVMSA-2019-0008)NessusOracleVM Local Security Checks
medium
75915openSUSE Security Update : libpolkit0 (openSUSE-SU-2011:0413-1)NessusSuSE Local Security Checks
medium
75605openSUSE Security Update : libpolkit0 (openSUSE-SU-2011:0412-1)NessusSuSE Local Security Checks
medium
68258Oracle Linux 6 : polkit (ELSA-2011-0455)NessusOracle Linux Local Security Checks
medium
61021Scientific Linux Security Update : polkit on SL6.x i386/x86_64NessusScientific Linux Local Security Checks
medium
59622GLSA-201204-06 : PolicyKit: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
56414Debian DSA-2319-1 : policykit-1 - race conditionNessusDebian Local Security Checks
medium
55075Ubuntu 9.10 / 10.04 LTS / 10.10 : policykit-1 vulnerability (USN-1117-1)NessusUbuntu Local Security Checks
medium
54903Slackware 13.1 / current : polkit (SSA:2011-109-01)NessusSlackware Local Security Checks
medium
53910Mandriva Linux Security Advisory : polkit (MDVSA-2011:086)NessusMandriva Local Security Checks
medium
53849Fedora 14 : polkit-0.98-5.fc14 (2011-5676)NessusFedora Local Security Checks
medium
53537Fedora 15 : polkit-0.101-5.fc15 (2011-5589)NessusFedora Local Security Checks
medium
53500RHEL 6 : polkit (RHSA-2011:0455)NessusRed Hat Local Security Checks
medium