CVE-2011-1013

HIGH

Description

Integer signedness error in the drm_modeset_ctl function in (1) drivers/gpu/drm/drm_irq.c in the Direct Rendering Manager (DRM) subsystem in the Linux kernel before 2.6.38 and (2) sys/dev/pci/drm/drm_irq.c in the kernel in OpenBSD before 4.9 allows local users to trigger out-of-bounds write operations, and consequently cause a denial of service (system crash) or possibly have unspecified other impact, via a crafted num_crtcs (aka vb_num) structure member in an ioctl argument.

References

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=1922756124ddd53846877416d92ba4a802bc658f

http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.38

http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/drm/drm_irq.c

http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/drm/drm_irq.c.diff?r1=1.41;r2=1.42;f=h

http://www.securityfocus.com/bid/47639

https://bugzilla.redhat.com/show_bug.cgi?id=679925

https://exchange.xforce.ibmcloud.com/vulnerabilities/67199

Details

Source: MITRE

Published: 2011-05-09

Updated: 2020-08-05

Type: CWE-787

Risk Information

CVSS v2.0

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:o:openbsd:openbsd:*:*:*:*:*:*:*:* versions up to 4.8 (inclusive)

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
75879openSUSE Security Update : kernel (openSUSE-SU-2011:0416-1)NessusSuSE Local Security Checks
high
75555openSUSE Security Update : kernel (openSUSE-SU-2011:0861-1)NessusSuSE Local Security Checks
high
68416Oracle Linux 5 / 6 : Unbreakable Enterprise kernel (ELSA-2011-2015)NessusOracle Linux Local Security Checks
high
68273Oracle Linux 6 : kernel (ELSA-2011-0498)NessusOracle Linux Local Security Checks
high
61035Scientific Linux Security Update : kernel on SL6.x i386/x86_64NessusScientific Linux Local Security Checks
high
56192USN-1204-1 : linux-fsl-imx51 vulnerabilitiesNessusUbuntu Local Security Checks
high
56190USN-1202-1 : linux-ti-omap4 vulnerabilitiesNessusUbuntu Local Security Checks
high
55785Ubuntu 10.04 LTS : linux-lts-backport-maverick vulnerabilities (USN-1187-1)NessusUbuntu Local Security Checks
high
55591Ubuntu 11.04 : linux vulnerabilities (USN-1167-1)NessusUbuntu Local Security Checks
high
55589Ubuntu 10.10 : linux-mvl-dove vulnerabilities (USN-1159-1)NessusUbuntu Local Security Checks
high
55521Ubuntu 10.04 LTS : linux-mvl-dove vulnerabilities (USN-1162-1)NessusUbuntu Local Security Checks
high
55454Ubuntu 10.10 : linux vulnerabilities (USN-1160-1)NessusUbuntu Local Security Checks
high
55386Fedora 13 : kernel-2.6.34.9-69.fc13 (2011-6447)NessusFedora Local Security Checks
high
55104Ubuntu 10.04 LTS : linux, linux-ec2 vulnerabilities (USN-1141-1)NessusUbuntu Local Security Checks
high
53867RHEL 6 : kernel (RHSA-2011:0498)NessusRed Hat Local Security Checks
high
53571SuSE 11.1 Security Update : Linux kernel (SAT Patch Number 4376)NessusSuSE Local Security Checks
high
53570SuSE 11.1 Security Update : Linux kernel (SAT Patch Numbers 4384 / 4386)NessusSuSE Local Security Checks
high