CVE-2011-0905

LOW
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The rfbSendFramebufferUpdate function in server/libvncserver/rfbserver.c in vino-server in Vino 2.x before 2.28.3, 2.32.x before 2.32.2, 3.0.x before 3.0.2, and 3.1.x before 3.1.1, when tight encoding is used, allows remote authenticated users to cause a denial of service (daemon crash) via crafted dimensions in a framebuffer update request that triggers an out-of-bounds read operation.

References

http://ftp.gnome.org/pub/GNOME/sources/vino/2.28/vino-2.28.3.news

http://ftp.gnome.org/pub/GNOME/sources/vino/2.32/vino-2.32.2.news

http://ftp.gnome.org/pub/GNOME/sources/vino/3.0/vino-3.0.2.news

http://git.gnome.org/browse/vino/commit/?id=0c2c9175963fc56bf2af10e42867181332f96ce0

http://git.gnome.org/browse/vino/commit/?id=456dadbb5c5971d3448763a44c05b9ad033e522f

http://git.gnome.org/browse/vino/commit/?id=8beefcf7792d343c10c919ee0c928c81f73b1279

http://git.gnome.org/browse/vino/commit/?id=d050a22b1c284b633c407ef92fde95c47e8fdb8a

http://git.gnome.org/browse/vino/commit/?id=dff52694a384fe95195f2211254026b752d63ec4

http://git.gnome.org/browse/vino/commit/?id=e17bd4e369f90748654e31a4867211dc7610975d

http://git.gnome.org/browse/vino/log/?h=gnome-2-30

http://git.gnome.org/browse/vino/tree/NEWS

http://lists.opensuse.org/opensuse-security-announce/2011-05/msg00005.html

http://rhn.redhat.com/errata/RHSA-2013-0169.html

http://secunia.com/advisories/44410

http://secunia.com/advisories/44463

http://www.debian.org/security/2011/dsa-2238

http://www.mandriva.com/security/advisories?name=MDVSA-2011:087

http://www.securityfocus.com/bid/47681

http://www.ubuntu.com/usn/usn-1128-1/

http://www.vupen.com/english/advisories/2011/1144

https://bugzilla.gnome.org/show_bug.cgi?id=641803

https://bugzilla.redhat.com/show_bug.cgi?id=694456

https://exchange.xforce.ibmcloud.com/vulnerabilities/67244

Details

Source: MITRE

Published: 2011-05-10

Updated: 2017-08-17

Type: CWE-119

Risk Information

CVSS v2

Base Score: 3.5

Vector: AV:N/AC:M/Au:S/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 6.8

Severity: LOW

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:david_king:vino:2.10:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.11:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.12:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.13:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.13.5:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.14:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.15:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.16:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.17:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.17.2:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.17.4:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.17.5:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.17.92:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.18:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.18.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.19:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.19.5:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.19.90:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.19.92:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.20:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.20.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.21:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.21.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.21.2:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.21.3:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.21.90:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.21.91:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.21.92:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.22:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.22.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.22.2:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.23:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.23.5:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.23.90:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.23.91:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.23.92:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.24:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.24.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.25:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.25.3:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.25.4:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.25.5:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.25.90:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.25.91:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.25.92:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.26:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.26.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.26.2:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.27:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.27.5:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.27.90:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.27.91:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.27.92:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.28:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.28.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.28.2:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.32.0:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:2.32.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:3.0.0:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:3.0.1:*:*:*:*:*:*:*

cpe:2.3:a:david_king:vino:3.1:*:*:*:*:*:*:*

Tenable Plugins

View all (16 total)

IDNameProductFamilySeverity
79962GLSA-201412-09 : Multiple packages, Multiple vulnerabilities fixed in 2011NessusGentoo Local Security Checks
critical
76041openSUSE Security Update : vino (openSUSE-SU-2011:0481-1)NessusSuSE Local Security Checks
low
75768openSUSE Security Update : vino (openSUSE-SU-2011:0481-1)NessusSuSE Local Security Checks
low
68712Oracle Linux 6 : vino (ELSA-2013-0169)NessusOracle Linux Local Security Checks
medium
63671CentOS 6 : vino (CESA-2013:0169)NessusCentOS Local Security Checks
medium
63664Scientific Linux Security Update : vino on SL6.x i386/x86_64 (20130121)NessusScientific Linux Local Security Checks
medium
63641RHEL 6 : vino (RHSA-2013:0169)NessusRed Hat Local Security Checks
medium
57258SuSE 10 Security Update : vino (ZYPP Patch Number 7531)NessusSuSE Local Security Checks
low
55089Ubuntu 8.04 LTS / 10.04 LTS / 10.10 / 11.04 : vino vulnerabilities (USN-1128-1)NessusUbuntu Local Security Checks
low
55021SuSE 10 Security Update : vino (ZYPP Patch Number 7532)NessusSuSE Local Security Checks
low
55020SuSE 11.1 Security Update : vino (SAT Patch Number 4575)NessusSuSE Local Security Checks
low
54588Debian DSA-2238-1 : vino - several vulnerabilitiesNessusDebian Local Security Checks
low
54295Fedora 13 : vino-2.28.3-1.fc13 (2011-6778)NessusFedora Local Security Checks
low
54293Fedora 14 : vino-2.32.2-1.fc14 (2011-6773)NessusFedora Local Security Checks
low
54288Mandriva Linux Security Advisory : vino (MDVSA-2011:087)NessusMandriva Local Security Checks
low
53889openSUSE Security Update : vino (openSUSE-SU-2011:0481-1)NessusSuSE Local Security Checks
low