CVE-2011-0757

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

IBM DB2 9.1 before FP10, 9.5 before FP6a, and 9.7 before FP2 on Linux, UNIX, and Windows does not properly revoke the DBADM authority, which allows remote authenticated users to execute non-DDL statements by leveraging previous possession of this authority.

References

http://osvdb.org/70773

http://secunia.com/advisories/43148

http://www.ibm.com/support/docview.wss?uid=swg1IC66811

http://www.ibm.com/support/docview.wss?uid=swg1IC66814

http://www.ibm.com/support/docview.wss?uid=swg1IC66815

http://www.ibm.com/support/docview.wss?uid=swg21426108

http://www.securityfocus.com/bid/46064

http://www-01.ibm.com/support/docview.wss?crawler=1&uid=swg1IC66811

http://www-01.ibm.com/support/docview.wss?crawler=1&uid=swg1IC66814

http://www-01.ibm.com/support/docview.wss?crawler=1&uid=swg1IC66815

https://exchange.xforce.ibmcloud.com/vulnerabilities/65008

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A14295

Details

Source: MITRE

Published: 2011-02-02

Updated: 2017-09-19

Type: CWE-264

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
51840IBM DB2 9.1 < Fix Pack 10 Multiple VulnerabilitiesNessusDatabases
critical
5749IBM DB2 9.1 < 9.1 Fix Pack 10 Multiple VulnerabilitiesNessus Network MonitorDatabase
critical
5556IBM DB2 9.7 < 9.7 Fix Pack 2 Multiple VulnerabilitiesNessus Network MonitorDatabase
medium
46766IBM DB2 9.7 < Fix Pack 2 Multiple VulnerabilitiesNessusDatabases
medium