CVE-2011-0536

MEDIUM

Description

Multiple untrusted search path vulnerabilities in elf/dl-object.c in certain modified versions of the GNU C Library (aka glibc or libc6), including glibc-2.5-49.el5_5.6 and glibc-2.12-1.7.el6_0.3 in Red Hat Enterprise Linux, allow local users to gain privileges via a crafted dynamic shared object (DSO) in a subdirectory of the current working directory during execution of a (1) setuid or (2) setgid program that has $ORIGIN in (a) RPATH or (b) RUNPATH within the program itself or a referenced library. NOTE: this issue exists because of an incorrect fix for CVE-2010-3847.

References

http://lists.debian.org/debian-security-announce/2011/msg00005.html

http://openwall.com/lists/oss-security/2011/02/01/3

http://openwall.com/lists/oss-security/2011/02/03/2

http://secunia.com/advisories/43830

http://secunia.com/advisories/43989

http://secunia.com/advisories/46397

http://securitytracker.com/id?1025289

http://sourceware.org/git/?p=glibc.git;a=commit;h=96611391ad8823ba58405325d78cefeae5cdf699

http://www.mandriva.com/security/advisories?name=MDVSA-2011:178

http://www.redhat.com/support/errata/RHSA-2011-0412.html

http://www.redhat.com/support/errata/RHSA-2011-0413.html

http://www.securityfocus.com/archive/1/520102/100/0/threaded

http://www.ubuntu.com/usn/USN-1009-2

http://www.vmware.com/security/advisories/VMSA-2011-0012.html

http://www.vupen.com/english/advisories/2011/0863

https://bugzilla.redhat.com/show_bug.cgi?id=667974

https://launchpad.net/bugs/701783

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A13086

Details

Source: MITRE

Published: 2011-04-08

Updated: 2018-10-09

Risk Information

CVSS v2.0

Base Score: 6.9

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.4

Severity: MEDIUM

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
89680VMware ESX / ESXi Third-Party Libraries Multiple Vulnerabilities (VMSA-2011-0012) (remote check)NessusMisc.
high
89679VMware ESX Third-Party Libraries Multiple Vulnerabilities (VMSA-2011-0010) (remote check)NessusMisc.
high
81118OracleVM 3.2 : glibc (OVMSA-2015-0023) (GHOST)NessusOracleVM Local Security Checks
high
71167GLSA-201312-01 : GNU C Library: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
70880ESXi 5.0 < Build 515841 Multiple Vulnerabilities (remote check)NessusMisc.
high
68245Oracle Linux 6 : glibc (ELSA-2011-0413)NessusOracle Linux Local Security Checks
medium
68244Oracle Linux 5 : glibc (ELSA-2011-0412)NessusOracle Linux Local Security Checks
high
61008Scientific Linux Security Update : glibc on SL5.x,SL6.x i386/x86_64NessusScientific Linux Local Security Checks
medium
57201SuSE 10 Security Update : glibc (ZYPP Patch Number 7574)NessusSuSE Local Security Checks
medium
57106SuSE 11.1 Security Update : glibc (SAT Patch Number 4572)NessusSuSE Local Security Checks
high
56953Mandriva Linux Security Advisory : glibc (MDVSA-2011:178)NessusMandriva Local Security Checks
medium
56508VMSA-2011-0012 : VMware ESXi and ESX updates to third-party libraries and ESX Service ConsoleNessusVMware ESX Local Security Checks
high
55747VMSA-2011-0010 : VMware ESX third-party updates for Service Console packages glibc and dhcpNessusVMware ESX Local Security Checks
high
55442SuSE 10 Security Update : glibc (ZYPP Patch Number 7575)NessusSuSE Local Security Checks
medium
55441SuSE 11.1 Security Update : glibc (SAT Patch Number 4572)NessusSuSE Local Security Checks
high
55440SuSE9 Security Update : glibc (YOU Patch Number 12775)NessusSuSE Local Security Checks
medium
53430CentOS 5 : glibc (CESA-2011:0412)NessusCentOS Local Security Checks
high
53292RHEL 6 : glibc (RHSA-2011:0413)NessusRed Hat Local Security Checks
medium
53291RHEL 5 : glibc (RHSA-2011:0412)NessusRed Hat Local Security Checks
high
51501Ubuntu 8.04 LTS / 9.10 / 10.04 LTS / 10.10 : eglibc, glibc vulnerability (USN-1009-2)NessusUbuntu Local Security Checks
high
51422VMSA-2011-0001 : VMware ESX third-party updates for Service Console packages glibc, sudo, and openldapNessusVMware ESX Local Security Checks
high
50318Ubuntu 8.04 LTS / 9.04 / 9.10 / 10.04 LTS / 10.10 : glibc, eglibc vulnerabilities (USN-1009-1)NessusUbuntu Local Security Checks
high