CVE-2010-4258

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The do_exit function in kernel/exit.c in the Linux kernel before 2.6.36.2 does not properly handle a KERNEL_DS get_fs value, which allows local users to bypass intended access_ok restrictions, overwrite arbitrary kernel memory locations, and gain privileges by leveraging a (1) BUG, (2) NULL pointer dereference, or (3) page fault, as demonstrated by vectors involving the clear_child_tid feature and the splice system call.

References

http://archives.neohapsis.com/archives/fulldisclosure/2010-12/0086.html

http://blog.nelhage.com/2010/12/cve-2010-4258-from-dos-to-privesc/

http://code.google.com/p/chromium-os/issues/detail?id=10234

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=33dd94ae1ccbfb7bf0fb6c692bc3d1c4269e6177

http://googlechromereleases.blogspot.com/2011/01/chrome-os-beta-channel-update.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-December/052513.html

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00000.html

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00001.html

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00004.html

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00007.html

http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html

http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html

http://marc.info/?l=linux-kernel&m=129117048916957&w=2

http://openwall.com/lists/oss-security/2010/12/02/2

http://openwall.com/lists/oss-security/2010/12/02/3

http://openwall.com/lists/oss-security/2010/12/02/4

http://openwall.com/lists/oss-security/2010/12/02/7

http://openwall.com/lists/oss-security/2010/12/08/4

http://openwall.com/lists/oss-security/2010/12/08/5

http://openwall.com/lists/oss-security/2010/12/08/9

http://openwall.com/lists/oss-security/2010/12/09/14

http://openwall.com/lists/oss-security/2010/12/09/4

http://secunia.com/advisories/42745

http://secunia.com/advisories/42778

http://secunia.com/advisories/42801

http://secunia.com/advisories/42932

http://secunia.com/advisories/43056

http://secunia.com/advisories/43291

http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.36.2

http://www.mandriva.com/security/advisories?name=MDVSA-2011:029

http://www.vupen.com/english/advisories/2010/3321

http://www.vupen.com/english/advisories/2011/0012

http://www.vupen.com/english/advisories/2011/0124

http://www.vupen.com/english/advisories/2011/0213

http://www.vupen.com/english/advisories/2011/0298

http://www.vupen.com/english/advisories/2011/0375

https://bugzilla.redhat.com/show_bug.cgi?id=659567

https://lkml.org/lkml/2010/12/1/543

Details

Source: MITRE

Published: 2010-12-30

Updated: 2020-08-14

Type: CWE-269

Risk Information

CVSS v2

Base Score: 6.2

Vector: AV:L/AC:H/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 1.9

Severity: MEDIUM

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
79507OracleVM 2.2 : kernel (OVMSA-2013-0039)NessusOracleVM Local Security Checks
high
75553openSUSE Security Update : kernel (openSUSE-SU-2011:0004-1)NessusSuSE Local Security Checks
high
65101Ubuntu 10.04 LTS : linux-lts-backport-maverick vulnerabilities (USN-1083-1)NessusUbuntu Local Security Checks
critical
65103Ubuntu 10.04 LTS / 10.10 : linux-mvl-dove vulnerabilities (USN-1093-1)NessusUbuntu Local Security Checks
high
59154SuSE 10 Security Update : the Linux kernel (ZYPP Patch Number 7304)NessusSuSE Local Security Checks
medium
58229SuSE9 Security Update : the Linux kernel (YOU Patch Number 12677)NessusSuSE Local Security Checks
high
55591Ubuntu 11.04 : linux vulnerabilities (USN-1167-1)NessusUbuntu Local Security Checks
medium
55530USN-1164-1 : linux-fsl-imx51 vulnerabilitiesNessusUbuntu Local Security Checks
high
55069Ubuntu 6.06 LTS : linux-source-2.6.15 vulnerabilities (USN-1111-1)NessusUbuntu Local Security Checks
high
53741openSUSE Security Update : kernel-debug (openSUSE-SU-2011:0003-1)NessusSuSE Local Security Checks
high
53303Ubuntu 8.04 LTS : linux vulnerabilities (USN-1105-1)NessusUbuntu Local Security Checks
high
51953SuSE9 Security Update : the Linux kernel (YOU Patch Number 12672)NessusSuSE Local Security Checks
high
51847Ubuntu 10.04 LTS / 10.10 : linux, linux-ec2 vulnerabilities (USN-1054-1)NessusUbuntu Local Security Checks
high
51818Debian DSA-2153-1 : linux-2.6 - privilege escalation/denial of service/information leakNessusDebian Local Security Checks
high
51752SuSE 10 Security Update : the Linux kernel (ZYPP Patch Number 7303)NessusSuSE Local Security Checks
medium
51614SuSE 11.1 Security Update : Linux kernel (SAT Patch Numbers 3760 / 3762 / 3763)NessusSuSE Local Security Checks
high
51374Fedora 13 : kernel-2.6.34.7-66.fc13 (2010-18983)NessusFedora Local Security Checks
high