CVE-2010-2945

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The default configuration of SLiM before 1.3.2 places ./ (dot slash) at the beginning of the default_path option, which might allow local users to gain privileges via a Trojan horse program in the current working directory, related to slim.conf and cfg.cpp.

References

http://secunia.com/advisories/41005

http://svn.berlios.de/viewvc/slim?view=revision&revision=171

http://www.openwall.com/lists/oss-security/2010/08/19/8

http://www.openwall.com/lists/oss-security/2010/08/20/10

Details

Source: MITRE

Published: 2010-08-30

Updated: 2010-08-31

Type: CWE-16

Risk Information

CVSS v2

Base Score: 6.9

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.4

Severity: MEDIUM

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
79961GLSA-201412-08 : Multiple packages, Multiple vulnerabilities fixed in 2010NessusGentoo Local Security Checks
critical
49160Fedora 12 : slim-1.3.2-2.fc12 (2010-13897)NessusFedora Local Security Checks
medium
49159Fedora 13 : slim-1.3.2-2.fc13 (2010-13890)NessusFedora Local Security Checks
medium
49158Fedora 14 : slim-1.3.2-2.fc14 (2010-13843)NessusFedora Local Security Checks
medium
48380FreeBSD : slim -- insecure PATH assignment (68c7187a-abd2-11df-9be6-0015587e2cc1)NessusFreeBSD Local Security Checks
medium