CVE-2010-2301

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Cross-site scripting (XSS) vulnerability in editing/markup.cpp in WebCore in WebKit in Google Chrome before 5.0.375.70 allows remote attackers to inject arbitrary web script or HTML via vectors related to the node.innerHTML property of a TEXTAREA element. NOTE: this might overlap CVE-2010-1762.

References

http://code.google.com/p/chromium/issues/detail?id=43902

http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html

http://secunia.com/advisories/40072

http://secunia.com/advisories/43068

http://www.vupen.com/english/advisories/2011/0212

https://bugs.webkit.org/show_bug.cgi?id=38922

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11861

Details

Source: MITRE

Published: 2010-06-15

Updated: 2020-08-06

Type: CWE-79

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
75629openSUSE Security Update : libwebkit (openSUSE-SU-2011:0024-1)NessusSuSE Local Security Checks
critical
53764openSUSE Security Update : libwebkit (openSUSE-SU-2011:0024-1)NessusSuSE Local Security Checks
critical
46850Google Chrome < 5.0.375.70 Multiple VulnerabilitiesNessusWindows
high
5567Google Chrome < 5.0.375.70 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high