CVE-2010-1769

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

WebKit in Apple iTunes before 9.2 on Windows, and Apple iOS before 4 on the iPhone and iPod touch, accesses out-of-bounds memory during the handling of tables, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted HTML document, a different vulnerability than CVE-2010-1387 and CVE-2010-1763.

References

http://lists.apple.com/archives/security-announce/2010//Jun/msg00002.html

http://lists.apple.com/archives/security-announce/2010/Jun/msg00003.html

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html

http://secunia.com/advisories/40196

http://secunia.com/advisories/43068

http://securitytracker.com/id?1024108

http://support.apple.com/kb/HT4220

http://support.apple.com/kb/HT4225

http://www.securityfocus.com/bid/41016

http://www.vupen.com/english/advisories/2010/1512

http://www.vupen.com/english/advisories/2011/0212

https://exchange.xforce.ibmcloud.com/vulnerabilities/59508

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7178

Details

Source: MITRE

Published: 2010-06-18

Updated: 2017-09-19

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

AND

OR

cpe:2.3:a:apple:itunes:7.0.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.0.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.0.2:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.0.2:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.1.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.1.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.2.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.3.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.3.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.3.2:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.3.2:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.4:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.4.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.4.1:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.4.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.4.2:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.4.2:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.4.3:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.5:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.5.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.6:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.6.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.6.1:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.6.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.6.2:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.6.2:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.7:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.7.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.7.1:*:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:7.7.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.0.0:*:*:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.0.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.0.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.0.2:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.1.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.2:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:8.2.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:9.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:9.0.0:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:9.0.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:9.0.2:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:9.0.3:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:9.1:-:windows:*:*:*:*:*

cpe:2.3:a:apple:itunes:*:-:windows:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows_7:*:*:*:*:*:*:*:*

cpe:2.3:o:microsoft:windows_vista:*:*:*:*:*:*:*:*

cpe:2.3:o:microsoft:windows_xp:*:*:*:*:*:*:*:*

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
75629openSUSE Security Update : libwebkit (openSUSE-SU-2011:0024-1)NessusSuSE Local Security Checks
critical
53764openSUSE Security Update : libwebkit (openSUSE-SU-2011:0024-1)NessusSuSE Local Security Checks
critical
5578Apple iOS < 4.0 Multiple VulnerabilitiesNessus Network MonitorMobile Devices
critical
5573iTunes < 9.2 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
47038Apple iTunes < 9.2 Multiple Vulnerabilities (uncredentialed check)NessusPeer-To-Peer File Sharing
high
47037Apple iTunes < 9.2 Multiple Vulnerabilities (credentialed check)NessusWindows
high