CVE-2010-1440

MEDIUM

Description

Multiple integer overflows in dvipsk/dospecial.c in dvips in TeX Live 2009 and earlier, and teTeX, allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a special command in a DVI file, related to the (1) predospecial and (2) bbdospecial functions, a different vulnerability than CVE-2010-0739.

References

http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041573.html

http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2010-06/msg00001.html

http://security.gentoo.org/glsa/glsa-201206-28.xml

http://www.ubuntu.com/usn/USN-937-1

https://bugzilla.redhat.com/show_bug.cgi?id=586819

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10068

Details

Source: MITRE

Published: 2010-05-07

Updated: 2017-09-19

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM