CVE-2010-1322

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The merge_authdata function in kdc_authdata.c in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8.x before 1.8.4 does not properly manage an index into an authorization-data list, which allows remote attackers to cause a denial of service (daemon crash), or possibly obtain sensitive information, spoof authorization, or execute arbitrary code, via a TGS request that triggers an uninitialized pointer dereference, as demonstrated by a request from a Windows Active Directory client.

References

http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00006.html

http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2010-006.txt

http://www.mandriva.com/security/advisories?name=MDVSA-2010:202

http://www.redhat.com/support/errata/RHSA-2010-0863.html

http://www.securityfocus.com/archive/1/514144/100/0/threaded

http://www.securityfocus.com/bid/43756

http://www.ubuntu.com/usn/USN-999-1

http://www.vupen.com/english/advisories/2010/2865

Details

Source: MITRE

Published: 2010-10-07

Updated: 2020-01-21

Type: CWE-20

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
80653Oracle Solaris Third-Party Patch Update : kerberos (cve_2010_1322_improper_input)NessusSolaris Local Security Checks
medium
75558openSUSE Security Update : krb5 (openSUSE-SU-2010:0709-1)NessusSuSE Local Security Checks
medium
60894Scientific Linux Security Update : krb5 on SL6.x i386/x86_64NessusScientific Linux Local Security Checks
medium
57655GLSA-201201-13 : MIT Kerberos 5: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
50635RHEL 6 : krb5 (RHSA-2010:0863)NessusRed Hat Local Security Checks
medium
49988Fedora 14 : krb5-1.8.2-6.fc14 (2010-15803)NessusFedora Local Security Checks
medium
49972Mandriva Linux Security Advisory : krb5 (MDVSA-2010:202)NessusMandriva Local Security Checks
medium
49772Ubuntu 10.04 LTS / 10.10 : krb5 vulnerability (USN-999-1)NessusUbuntu Local Security Checks
medium