CVE-2010-1215

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Mozilla Firefox 3.6.x before 3.6.7 and Thunderbird 3.1.x before 3.1.1 do not properly implement access to a content object through a SafeJSObjectWrapper (aka SJOW) wrapper, which allows remote attackers to execute arbitrary JavaScript code with chrome privileges by leveraging "access to an object from the chrome scope."

References

http://www.mozilla.org/security/announce/2010/mfsa2010-38.html

https://bugzilla.mozilla.org/show_bug.cgi?id=567069

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11527

Details

Source: MITRE

Published: 2010-07-30

Updated: 2017-09-19

Type: CWE-94

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
75646openSUSE Security Update : MozillaFirefox (MozillaFirefox-2807)NessusSuSE Local Security Checks
critical
68068Oracle Linux 4 / 5 : firefox (ELSA-2010-0547)NessusOracle Linux Local Security Checks
high
68067Oracle Linux 3 / 4 : seamonkey (ELSA-2010-0546)NessusOracle Linux Local Security Checks
high
63939RHEL 5 : thunderbird (RHSA-2010:0545)NessusRed Hat Local Security Checks
critical
63402GLSA-201301-01 : Mozilla Products: Multiple vulnerabilities (BEAST)NessusGentoo Local Security Checks
critical
60818Scientific Linux Security Update : firefox on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
48342CentOS 3 : seamonkey (CESA-2010:0546)NessusCentOS Local Security Checks
high
47881RHEL 4 / 5 : firefox (RHSA-2010:0547)NessusRed Hat Local Security Checks
high
47880RHEL 3 / 4 : seamonkey (RHSA-2010:0546)NessusRed Hat Local Security Checks
high
47856Ubuntu 8.04 LTS / 10.04 LTS : firefox, firefox-3.0, xulrunner-1.9.2 vulnerability (USN-957-2)NessusUbuntu Local Security Checks
critical
47826Ubuntu 8.04 LTS / 10.04 LTS : firefox, firefox-3.0, xulrunner-1.9.2 vulnerabilities (USN-957-1)NessusUbuntu Local Security Checks
high
47825Ubuntu 9.04 / 9.10 : ant, apturl, epiphany-browser, gluezilla, gnome-python-extras, liferea, mozvoikko, openjdk-6, packagekit, ubufox, webfav, yelp update (USN-930-5)NessusUbuntu Local Security Checks
critical
47824Ubuntu 9.04 / 9.10 : firefox-3.0, firefox-3.5, xulrunner-1.9.2 vulnerabilities (USN-930-4)NessusUbuntu Local Security Checks
critical
47813Fedora 13 : sunbird-1.0-0.26.b2pre.fc13 / thunderbird-3.1.1-1.fc13 (2010-11379)NessusFedora Local Security Checks
high
47809Fedora 13 : firefox-3.6.7-1.fc13 / galeon-2.0.7-30.fc13 / gnome-python2-extras-2.25.3-20.fc13 / etc (2010-11345)NessusFedora Local Security Checks
high
47806CentOS 4 / 5 : firefox (CESA-2010:0547)NessusCentOS Local Security Checks
high
47805CentOS 5 : thunderbird (CESA-2010:0545)NessusCentOS Local Security Checks
critical
47794FreeBSD : mozilla -- multiple vulnerabilities (8c2ea875-9499-11df-8e32-000f20797ede)NessusFreeBSD Local Security Checks
high
47782Firefox 3.6 < 3.6.7 Multiple VulnerabilitiesNessusWindows
high
800780Firefox 3.6.x < 3.6.7 Multiple VulnerabilitiesLog Correlation EngineWeb Clients
high
5607Mozilla Firefox 3.6.x < 3.6.7 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
47784Mozilla Thunderbird 3.1.x < 3.1.1 Multiple VulnerabilitiesNessusWindows
high