CVE-2010-1203

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The JavaScript engine in Mozilla Firefox 3.6.x before 3.6.4 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors that trigger an assertion failure in jstracer.cpp.

References

http://lists.opensuse.org/opensuse-security-announce/2010-07/msg00005.html

http://secunia.com/advisories/40323

http://secunia.com/advisories/40326

http://secunia.com/advisories/40401

http://secunia.com/advisories/40481

http://support.avaya.com/css/P8/documents/100091069

http://ubuntu.com/usn/usn-930-1

http://www.mandriva.com/security/advisories?name=MDVSA-2010:125

http://www.mozilla.org/security/announce/2010/mfsa2010-26.html

http://www.redhat.com/support/errata/RHSA-2010-0500.html

http://www.redhat.com/support/errata/RHSA-2010-0501.html

http://www.securityfocus.com/bid/41050

http://www.securityfocus.com/bid/41099

http://www.securitytracker.com/id?1024138

http://www.securitytracker.com/id?1024139

http://www.ubuntu.com/usn/usn-930-2

http://www.vupen.com/english/advisories/2010/1551

http://www.vupen.com/english/advisories/2010/1557

http://www.vupen.com/english/advisories/2010/1640

http://www.vupen.com/english/advisories/2010/1773

https://bugzilla.mozilla.org/show_bug.cgi?id=546611

https://bugzilla.mozilla.org/show_bug.cgi?id=557946

https://exchange.xforce.ibmcloud.com/vulnerabilities/59662

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10401

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A8317

Details

Source: MITRE

Published: 2010-06-24

Updated: 2017-09-19

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Tenable Plugins

View all (37 total)

IDNameProductFamilySeverity
68055Oracle Linux 5 : firefox (ELSA-2010-0501)NessusOracle Linux Local Security Checks
critical
68054Oracle Linux 4 : firefox (ELSA-2010-0500)NessusOracle Linux Local Security Checks
critical
68053Oracle Linux 3 / 4 : seamonkey (ELSA-2010-0499)NessusOracle Linux Local Security Checks
critical
63402GLSA-201301-01 : Mozilla Products: Multiple vulnerabilities (BEAST)NessusGentoo Local Security Checks
critical
60808Scientific Linux Security Update : firefox on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
critical
60807Scientific Linux Security Update : firefox on SL4.x i386/x86_64NessusScientific Linux Local Security Checks
critical
50873SuSE 11 / 11.1 Security Update : Mozilla Firefox (SAT Patch Numbers 2608 / 2609)NessusSuSE Local Security Checks
critical
49893SuSE 10 Security Update : Mozilla Firefox (ZYPP Patch Number 7083)NessusSuSE Local Security Checks
critical
48265CentOS 4 : firefox (CESA-2010:0500)NessusCentOS Local Security Checks
critical
47855Ubuntu 9.04 / 9.10 : firefox, firefox-3.0, xulrunner-1.9.2 vulnerability (USN-930-6)NessusUbuntu Local Security Checks
critical
47825Ubuntu 9.04 / 9.10 : ant, apturl, epiphany-browser, gluezilla, gnome-python-extras, liferea, mozvoikko, openjdk-6, packagekit, ubufox, webfav, yelp update (USN-930-5)NessusUbuntu Local Security Checks
critical
47824Ubuntu 9.04 / 9.10 : firefox-3.0, firefox-3.5, xulrunner-1.9.2 vulnerabilities (USN-930-4)NessusUbuntu Local Security Checks
critical
47788CentOS 3 / 4 : seamonkey (CESA-2010:0499)NessusCentOS Local Security Checks
critical
47693openSUSE Security Update : MozillaFirefox (openSUSE-SU-2010:0358-2)NessusSuSE Local Security Checks
critical
47691openSUSE Security Update : MozillaFirefox (openSUSE-SU-2010:0358-2)NessusSuSE Local Security Checks
critical
47689openSUSE Security Update : MozillaFirefox (openSUSE-SU-2010:0358-2)NessusSuSE Local Security Checks
critical
47618Ubuntu 10.04 LTS : thunderbird vulnerabilities (USN-943-1)NessusUbuntu Local Security Checks
critical
47574Ubuntu 8.04 LTS : firefox regression (USN-930-3)NessusUbuntu Local Security Checks
critical
47226Fedora 13 : seamonkey-2.0.5-1.fc13 (2010-10363)NessusFedora Local Security Checks
critical
47225Fedora 13 : firefox-3.6.4-1.fc13 / galeon-2.0.7-29.fc13 / gnome-python2-extras-2.25.3-19.fc13 / etc (2010-10361)NessusFedora Local Security Checks
critical
47222Fedora 12 : seamonkey-2.0.5-1.fc12 (2010-10329)NessusFedora Local Security Checks
critical
47162Ubuntu 8.04 LTS : apturl, epiphany-browser, gecko-sharp, gnome-python-extras, liferea, rhythmbox, totem, ubufox, yelp update (USN-930-2)NessusUbuntu Local Security Checks
critical
47161Ubuntu 8.04 LTS / 10.04 LTS : firefox, firefox-3.0, xulrunner-1.9.2 vulnerabilities (USN-930-1)NessusUbuntu Local Security Checks
critical
47132Mandriva Linux Security Advisory : firefox (MDVSA-2010:125)NessusMandriva Local Security Checks
high
47130FreeBSD : mozilla -- multiple vulnerabilities (99858b7c-7ece-11df-a007-000f20797ede)NessusFreeBSD Local Security Checks
critical
47129CentOS 5 : firefox (CESA-2010:0501)NessusCentOS Local Security Checks
critical
801275Mozilla Thunderbird < 3.0.5 Multiple VulnerabilitiesLog Correlation EngineSMTP Clients
high
800758Firefox < 3.5.10 Multiple VulnerabilitiesLog Correlation EngineWeb Clients
high
800742Firefox 3.6.x < 3.6.4 Multiple VulnerabilitiesLog Correlation EngineWeb Clients
high
5582Mozilla Thunderbird < 3.0.5 Multiple VulnerabilitiesNessus Network MonitorSMTP Clients
medium
5581SeaMonkey < 2.0.5 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
5580Mozilla Firefox 3.6.x < 3.6.4 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
5579Mozilla Firefox < 3.5.10 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
47124Firefox 3.6 < 3.6.4 Multiple VulnerabilitiesNessusWindows
high
47119RHEL 5 : firefox (RHSA-2010:0501)NessusRed Hat Local Security Checks
critical
47118RHEL 4 : firefox (RHSA-2010:0500)NessusRed Hat Local Security Checks
critical
47117RHEL 3 / 4 : seamonkey (RHSA-2010:0499)NessusRed Hat Local Security Checks
critical