CVE-2010-1141

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

VMware Tools in VMware Workstation 6.5.x before 6.5.4 build 246459; VMware Player 2.5.x before 2.5.4 build 246459; VMware ACE 2.5.x before 2.5.4 build 246459; VMware Server 2.x before 2.0.2 build 203138; VMware Fusion 2.x before 2.0.6 build 246742; VMware ESXi 3.5 and 4.0; and VMware ESX 2.5.5, 3.0.3, 3.5, and 4.0 does not properly access libraries, which allows user-assisted remote attackers to execute arbitrary code by tricking a Windows guest OS user into clicking on a file that is stored on a network share.

References

http://archives.neohapsis.com/archives/bugtraq/2010-04/0077.html

http://archives.neohapsis.com/archives/fulldisclosure/2010-04/0121.html

http://lists.vmware.com/pipermail/security-announce/2010/000090.html

http://secunia.com/advisories/39198

http://secunia.com/advisories/39206

http://security.gentoo.org/glsa/glsa-201209-25.xml

http://www.securitytracker.com/id?1023832

http://www.securitytracker.com/id?1023833

http://www.vmware.com/security/advisories/VMSA-2010-0007.html

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7020

Details

Source: MITRE

Published: 2010-04-12

Updated: 2017-09-19

Type: CWE-264

Risk Information

CVSS v2

Base Score: 8.5

Vector: AV:N/AC:M/Au:S/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 6.8

Severity: HIGH

Vulnerable Software

Configuration 1

AND

OR

cpe:2.3:a:vmware:workstation:6.5.0:*:*:*:*:*:*:*

cpe:2.3:a:vmware:workstation:6.5.1:*:*:*:*:*:*:*

cpe:2.3:a:vmware:workstation:6.5.2:*:*:*:*:*:*:*

cpe:2.3:a:vmware:workstation:6.5.3:*:*:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Configuration 2

AND

OR

cpe:2.3:a:vmware:player:2.5:*:*:*:*:*:*:*

cpe:2.3:a:vmware:player:2.5.1:*:*:*:*:*:*:*

cpe:2.3:a:vmware:player:2.5.2:*:*:*:*:*:*:*

cpe:2.3:a:vmware:player:2.5.3:*:*:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Configuration 3

AND

OR

cpe:2.3:a:vmware:ace:2.5.0:*:*:*:*:*:*:*

cpe:2.3:a:vmware:ace:2.5.1:*:*:*:*:*:*:*

cpe:2.3:a:vmware:ace:2.5.2:*:*:*:*:*:*:*

cpe:2.3:a:vmware:ace:2.5.3:*:*:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Configuration 4

AND

OR

cpe:2.3:a:vmware:server:2.0.0:*:*:*:*:*:*:*

cpe:2.3:a:vmware:server:2.0.1:*:*:*:*:*:*:*

cpe:2.3:a:vmware:server:2.0.2:*:*:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Configuration 5

AND

OR

cpe:2.3:a:vmware:fusion:2.0:*:*:*:*:*:*:*

cpe:2.3:a:vmware:fusion:2.0.1:*:*:*:*:*:*:*

cpe:2.3:a:vmware:fusion:2.0.2:*:*:*:*:*:*:*

cpe:2.3:a:vmware:fusion:2.0.3:*:*:*:*:*:*:*

cpe:2.3:a:vmware:fusion:2.0.4:*:*:*:*:*:*:*

cpe:2.3:a:vmware:fusion:2.0.5:*:*:*:*:*:*:*

cpe:2.3:a:vmware:fusion:3.0:*:*:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Configuration 6

AND

OR

cpe:2.3:a:vmware:esxi:3.5:*:*:*:*:*:*:*

cpe:2.3:a:vmware:esxi:4.0:*:*:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Configuration 7

AND

OR

cpe:2.3:a:vmware:esx:2.5.5:*:*:*:*:*:*:*

cpe:2.3:a:vmware:esx:3.0.3:*:*:*:*:*:*:*

cpe:2.3:a:vmware:esx:3.5:*:*:*:*:*:*:*

cpe:2.3:a:vmware:esx:4.0:*:*:*:*:*:*:*

OR

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
89739VMware ESX Multiple Vulnerabilities (VMSA-2010-0007) (remote check)NessusVMware ESX Local Security Checks
critical
62383GLSA-201209-25 : VMware Player, Server, Workstation: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
56246VMSA-2010-0007 : VMware hosted products, vCenter Server and ESX patches resolve multiple security issuesNessusVMware ESX Local Security Checks
critical
45541VMware Products Multiple Vulnerabilities (VMSA-2010-0007)NessusWindows
high