CVE-2010-0739

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Integer overflow in the predospecial function in dospecial.c in dvips in (1) TeX Live and (2) teTeX might allow user-assisted remote attackers to execute arbitrary code via a crafted DVI file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

References

http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-stable.git;a=blob;f=source/xapps-extra/tetex/texlive-CVE-2010-0739-int-overflow.patch

http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041573.html

http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2010-06/msg00001.html

http://secunia.com/advisories/39390

http://security.gentoo.org/glsa/glsa-201206-28.xml

http://www.securityfocus.com/bid/39500

http://www.ubuntu.com/usn/USN-937-1

https://bugzilla.redhat.com/show_bug.cgi?id=572941

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11468

Details

Source: MITRE

Published: 2010-04-16

Updated: 2017-09-19

Type: CWE-189

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (23 total)

IDNameProductFamilySeverity
68040Oracle Linux 3 : tetex (ELSA-2010-0401)NessusOracle Linux Local Security Checks
medium
68039Oracle Linux 5 : tetex (ELSA-2010-0400)NessusOracle Linux Local Security Checks
high
68038Oracle Linux 4 : tetex (ELSA-2010-0399)NessusOracle Linux Local Security Checks
high
60791Scientific Linux Security Update : tetex on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
60790Scientific Linux Security Update : tetex on SL4.x i386/x86_64NessusScientific Linux Local Security Checks
high
60789Scientific Linux Security Update : tetex on SL3.x i386/x86_64NessusScientific Linux Local Security Checks
medium
59701GLSA-201206-28 : TeX Live: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
51761SuSE 10 Security Update : TeX (ZYPP Patch Number 7020)NessusSuSE Local Security Checks
medium
50963SuSE 11 Security Update : TeX (SAT Patch Number 2393)NessusSuSE Local Security Checks
medium
47485Fedora 13 : texlive-2007-51.fc13 (2010-8314)NessusFedora Local Security Checks
medium
47481Fedora 11 : texlive-2007-47.fc11 (2010-8273)NessusFedora Local Security Checks
medium
47479Fedora 12 : texlive-2007-48.fc12 (2010-8242)NessusFedora Local Security Checks
medium
46760CentOS 5 : tetex (CESA-2010:0400)NessusCentOS Local Security Checks
high
46344openSUSE Security Update : texlive (openSUSE-SU-2010:0251-1)NessusSuSE Local Security Checks
medium
46342openSUSE Security Update : texlive (openSUSE-SU-2010:0251-1)NessusSuSE Local Security Checks
medium
46340openSUSE Security Update : texlive (openSUSE-SU-2010:0251-1)NessusSuSE Local Security Checks
medium
46330Mandriva Linux Security Advisory : tetex (MDVSA-2010:094)NessusMandriva Local Security Checks
high
46310RHEL 3 : tetex (RHSA-2010:0401)NessusRed Hat Local Security Checks
medium
46309RHEL 5 : tetex (RHSA-2010:0400)NessusRed Hat Local Security Checks
high
46308RHEL 4 : tetex (RHSA-2010:0399)NessusRed Hat Local Security Checks
high
46258CentOS 3 : tetex (CESA-2010:0401)NessusCentOS Local Security Checks
medium
46257CentOS 4 : tetex (CESA-2010:0399)NessusCentOS Local Security Checks
high
46254Ubuntu 8.04 LTS / 9.04 / 9.10 / 10.04 LTS : texlive-bin vulnerabilities (USN-937-1)NessusUbuntu Local Security Checks
medium