CVE-2010-0164

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Use-after-free vulnerability in the imgContainer::InternalAddFrameHelper function in src/imgContainer.cpp in libpr0n in Mozilla Firefox 3.6 before 3.6.2 allows remote attackers to cause a denial of service (heap memory corruption and application crash) or possibly execute arbitrary code via a multipart/x-mixed-replace animation in which the frames have different bits-per-pixel (bpp) values.

References

http://www.mandriva.com/security/advisories?name=MDVSA-2010:070

http://www.mozilla.org/security/announce/2010/mfsa2010-09.html

http://www.securityfocus.com/archive/1/510535/100/0/threaded

http://www.securityfocus.com/bid/38918

http://www.securityfocus.com/bid/38921

http://www.vupen.com/english/advisories/2010/0692

http://www.zerodayinitiative.com/advisories/ZDI-10-047

https://bugzilla.mozilla.org/show_bug.cgi?id=547143

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A8703

Details

Source: MITRE

Published: 2010-03-25

Updated: 2018-10-10

Type: CWE-399

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:mozilla:firefox:3.6:*:*:*:*:*:*:*

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
63402GLSA-201301-01 : Mozilla Products: Multiple vulnerabilities (BEAST)NessusGentoo Local Security Checks
critical
45520Mandriva Linux Security Advisory : firefox (MDVSA-2010:070-1)NessusMandriva Local Security Checks
critical
801342Mozilla Firefox < 3.6.2 Multiple Vulnerabilities.Log Correlation EngineWeb Clients
high
5485Mozilla Firefox 3.6.x < 3.6.2 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
45133Firefox 3.6.x < 3.6.2 Multiple VulnerabilitiesNessusWindows
high