CVE-2010-0049

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Use-after-free vulnerability in WebKit in Apple Safari before 4.0.5 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via HTML elements with right-to-left (RTL) text directionality.

References

http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=863

http://lists.apple.com/archives/security-announce/2010/Jun/msg00003.html

http://lists.apple.com/archives/security-announce/2010/Mar/msg00000.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041383.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041432.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041436.html

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html

http://osvdb.org/62942

http://secunia.com/advisories/41856

http://secunia.com/advisories/43068

http://support.apple.com/kb/HT4070

http://support.apple.com/kb/HT4225

http://www.mandriva.com/security/advisories?name=MDVSA-2011:039

http://www.securityfocus.com/bid/38671

http://www.securitytracker.com/id?1023708

http://www.ubuntu.com/usn/USN-1006-1

http://www.vupen.com/english/advisories/2010/2722

http://www.vupen.com/english/advisories/2011/0212

http://www.vupen.com/english/advisories/2011/0552

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6810

Details

Source: MITRE

Published: 2010-03-15

Updated: 2017-09-19

Type: CWE-399

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Tenable Plugins

View all (15 total)

IDNameProductFamilySeverity
75629openSUSE Security Update : libwebkit (openSUSE-SU-2011:0024-1)NessusSuSE Local Security Checks
critical
56899Fedora 16 : kdelibs-4.7.3-5.fc16 (2011-16151)NessusFedora Local Security Checks
high
53764openSUSE Security Update : libwebkit (openSUSE-SU-2011:0024-1)NessusSuSE Local Security Checks
critical
52523Mandriva Linux Security Advisory : webkit (MDVSA-2011:039)NessusMandriva Local Security Checks
critical
50046Ubuntu 9.10 / 10.04 LTS / 10.10 : webkit vulnerabilities (USN-1006-1)NessusUbuntu Local Security Checks
critical
47489Fedora 13 : qt-4.6.2-17.fc13 (2010-8423)NessusFedora Local Security Checks
high
47488Fedora 11 : qt-4.6.2-17.fc11 (2010-8379)NessusFedora Local Security Checks
high
47487Fedora 12 : qt-4.6.2-17.fc12 (2010-8360)NessusFedora Local Security Checks
high
47365Fedora 11 : qt-4.6.2-8.fc11 (2010-4524)NessusFedora Local Security Checks
high
47364Fedora 13 : qt-4.6.2-8.fc13 (2010-4521)NessusFedora Local Security Checks
high
47363Fedora 12 : qt-4.6.2-8.fc12 (2010-4518)NessusFedora Local Security Checks
high
5578Apple iOS < 4.0 Multiple VulnerabilitiesNessus Network MonitorMobile Devices
critical
5361Safari < 4.0.5 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high
45045Safari < 4.0.5 Multiple VulnerabilitiesNessusWindows
high
45044Mac OS X : Apple Safari < 4.0.5NessusMacOS X Local Security Checks
high