CVE-2010-0027

high

Description

The URL validation functionality in Microsoft Internet Explorer 5.01, 6, 6 SP1, 7 and 8, and the ShellExecute API function in Windows 2000 SP4, XP SP2 and SP3, and Server 2003 SP2, does not properly process input parameters, which allows remote attackers to execute arbitrary local programs via a crafted URL, aka "URL Validation Vulnerability."

References

http://www.zerodayinitiative.com/advisories/ZDI-10-016/

http://www.us-cert.gov/cas/techalerts/TA10-040A.html

https://exchange.xforce.ibmcloud.com/vulnerabilities/55773

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A8464

http://www.securityfocus.com/archive/1/509470/100/0/threaded

https://docs.microsoft.com/en-us/security-updates/securitybulletins/2010/ms10-007

https://docs.microsoft.com/en-us/security-updates/securitybulletins/2010/ms10-002

Details

Source: MITRE

Published: 2010-01-22

Updated: 2021-07-23

Type: CWE-94

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH