CVE-2009-5026

MEDIUM

Description

The executable comment feature in MySQL 5.0.x before 5.0.93 and 5.1.x before 5.1.50, when running in certain slave configurations in which the slave is running a newer version than the master, allows remote attackers to execute arbitrary SQL commands via custom comments.

References

http://bugs.mysql.com/bug.php?id=49124

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-93.html

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-50.html

http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00007.html

http://seclists.org/oss-sec/2011/q4/101

http://secunia.com/advisories/49179

https://bugzilla.redhat.com/show_bug.cgi?id=640177

Details

Source: MITRE

Published: 2012-08-17

Updated: 2012-10-30

Type: CWE-89

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM