CVE-2009-0792

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images. NOTE: this issue exists because of an incomplete fix for CVE-2009-0583.

References

http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00010.html

http://lists.opensuse.org/opensuse-security-announce/2009-06/msg00003.html

http://secunia.com/advisories/34373

http://secunia.com/advisories/34667

http://secunia.com/advisories/34711

http://secunia.com/advisories/34726

http://secunia.com/advisories/34729

http://secunia.com/advisories/34732

http://secunia.com/advisories/35416

http://secunia.com/advisories/35559

http://secunia.com/advisories/35569

http://security.gentoo.org/glsa/glsa-201412-17.xml

http://sunsolve.sun.com/search/document.do?assetkey=1-26-262288-1

http://support.avaya.com/elmodocs2/security/ASA-2009-155.htm

http://wiki.rpath.com/Advisories:rPSA-2009-0060

http://www.mandriva.com/security/advisories?name=MDVSA-2009:095

http://www.mandriva.com/security/advisories?name=MDVSA-2009:096

http://www.redhat.com/support/errata/RHSA-2009-0420.html

http://www.redhat.com/support/errata/RHSA-2009-0421.html

http://www.securityfocus.com/archive/1/502757/100/0/threaded

http://www.vupen.com/english/advisories/2009/1708

https://bugzilla.redhat.com/show_bug.cgi?id=491853

https://exchange.xforce.ibmcloud.com/vulnerabilities/50381

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11207

https://usn.ubuntu.com/757-1/

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00211.html

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00217.html

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00460.html

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00461.html

Details

Source: MITRE

Published: 2009-04-14

Updated: 2018-10-10

Type: CWE-189

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Tenable Plugins

View all (26 total)

IDNameProductFamilySeverity
79970GLSA-201412-17 : GPL Ghostscript: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
67841Oracle Linux 5 : ghostscript (ELSA-2009-0421)NessusOracle Linux Local Security Checks
high
67840Oracle Linux 3 / 4 : ghostscript (ELSA-2009-0420)NessusOracle Linux Local Security Checks
high
60565Scientific Linux Security Update : ghostscript on SL3.x, SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
48223Debian DSA-2080-1 : ghostscript - several vulnerabilitiesNessusDebian Local Security Checks
critical
43741CentOS 5 : ghostscript (CESA-2009:0421)NessusCentOS Local Security Checks
high
42997Mandriva Linux Security Advisory : ghostscript (MDVSA-2009:311)NessusMandriva Local Security Checks
critical
41513SuSE 10 Security Update : GhostScript (ZYPP Patch Number 6245)NessusSuSE Local Security Checks
high
41396SuSE 11 Security Update : GhostScript (SAT Patch Number 876)NessusSuSE Local Security Checks
high
41395SuSE 11 Security Update : Ghostscript (SAT Patch Number 752)NessusSuSE Local Security Checks
high
41300SuSE9 Security Update : GhostScript (YOU Patch Number 12417)NessusSuSE Local Security Checks
high
40220openSUSE Security Update : ghostscript-devel (ghostscript-devel-877)NessusSuSE Local Security Checks
high
39968openSUSE Security Update : ghostscript-devel (ghostscript-devel-877)NessusSuSE Local Security Checks
high
39567Slackware 12.1 / 12.2 / current : ghostscript (SSA:2009-181-01)NessusSlackware Local Security Checks
high
38807openSUSE 10 Security Update : ghostscript-devel (ghostscript-devel-6246)NessusSuSE Local Security Checks
high
38164Mandriva Linux Security Advisory : ghostscript (MDVSA-2009:095)NessusMandriva Local Security Checks
high
37541Fedora 10 : argyllcms-1.0.3-4.fc10 (2009-3435)NessusFedora Local Security Checks
high
37438Ubuntu 6.06 LTS / 8.04 LTS / 8.10 : ghostscript, gs-esp, gs-gpl vulnerabilities (USN-757-1)NessusUbuntu Local Security Checks
high
37055Fedora 10 : ghostscript-8.63-6.fc10 (2009-3709)NessusFedora Local Security Checks
high
36706Fedora 10 : argyllcms-1.0.3-5.fc10 (2009-3740)NessusFedora Local Security Checks
high
36190Fedora 9 : argyllcms-1.0.3-5.fc9 (2009-3720)NessusFedora Local Security Checks
high
36166Fedora 9 : ghostscript-8.63-3.fc9 (2009-3710)NessusFedora Local Security Checks
high
36160RHEL 5 : ghostscript (RHSA-2009:0421)NessusRed Hat Local Security Checks
high
36159RHEL 3 / 4 : ghostscript (RHSA-2009:0420)NessusRed Hat Local Security Checks
high
36155CentOS 3 / 4 : ghostscript (CESA-2009:0420)NessusCentOS Local Security Checks
high
36125Fedora 9 : argyllcms-1.0.3-4.fc9 (2009-3430)NessusFedora Local Security Checks
high