CVE-2008-7256

LOW

Description

mm/shmem.c in the Linux kernel before 2.6.28-rc8, when strict overcommit is enabled and CONFIG_SECURITY is disabled, does not properly handle the export of shmemfs objects by knfsd, which allows attackers to cause a denial of service (NULL pointer dereference and knfsd crash) or possibly have unspecified other impact via unknown vectors. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-1643.

References

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=1b79cd04fab80be61dcd2732e2423aafde9a4c1c

http://www.kernel.org/pub/linux/kernel/v2.6/testing/v2.6.28/ChangeLog-2.6.28-rc8

http://www.mandriva.com/security/advisories?name=MDVSA-2010:198

http://www.openwall.com/lists/oss-security/2010/05/27/1

https://bugzilla.redhat.com/show_bug.cgi?id=595970

https://exchange.xforce.ibmcloud.com/vulnerabilities/59224

Details

Source: MITRE

Published: 2010-06-03

Updated: 2017-08-17

Risk Information

CVSS v2.0

Base Score: 1.2

Vector: AV:L/AC:H/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 1.9

Severity: LOW