CVE-2008-6679

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

References

http://bugs.ghostscript.com/show_bug.cgi?id=690211

http://lists.opensuse.org/opensuse-security-announce/2009-06/msg00003.html

http://secunia.com/advisories/34667

http://secunia.com/advisories/34729

http://secunia.com/advisories/34732

http://secunia.com/advisories/35416

http://secunia.com/advisories/35559

http://secunia.com/advisories/35569

http://sunsolve.sun.com/search/document.do?assetkey=1-26-262288-1

http://wiki.rpath.com/Advisories:rPSA-2009-0060

http://www.mandriva.com/security/advisories?name=MDVSA-2009:095

http://www.openwall.com/lists/oss-security/2009/04/01/10

http://www.redhat.com/support/errata/RHSA-2009-0421.html

http://www.securityfocus.com/archive/1/502757/100/0/threaded

http://www.vupen.com/english/advisories/2009/1708

https://bugzilla.redhat.com/show_bug.cgi?id=493445

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10019

https://usn.ubuntu.com/757-1/

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00460.html

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00461.html

Details

Source: MITRE

Published: 2009-04-08

Updated: 2018-10-11

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:ghostscript:ghostscript:8.62:*:*:*:*:*:*:*

Tenable Plugins

View all (16 total)

IDNameProductFamilySeverity
67841Oracle Linux 5 : ghostscript (ELSA-2009-0421)NessusOracle Linux Local Security Checks
high
60565Scientific Linux Security Update : ghostscript on SL3.x, SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
48223Debian DSA-2080-1 : ghostscript - several vulnerabilitiesNessusDebian Local Security Checks
critical
43741CentOS 5 : ghostscript (CESA-2009:0421)NessusCentOS Local Security Checks
high
42997Mandriva Linux Security Advisory : ghostscript (MDVSA-2009:311)NessusMandriva Local Security Checks
critical
41513SuSE 10 Security Update : GhostScript (ZYPP Patch Number 6245)NessusSuSE Local Security Checks
high
41396SuSE 11 Security Update : GhostScript (SAT Patch Number 876)NessusSuSE Local Security Checks
high
40220openSUSE Security Update : ghostscript-devel (ghostscript-devel-877)NessusSuSE Local Security Checks
high
39968openSUSE Security Update : ghostscript-devel (ghostscript-devel-877)NessusSuSE Local Security Checks
high
38807openSUSE 10 Security Update : ghostscript-devel (ghostscript-devel-6246)NessusSuSE Local Security Checks
high
38763FreeBSD : ghostscript -- buffer overflow vulnerability (f0f97b94-3f95-11de-a3fd-0030843d3802)NessusFreeBSD Local Security Checks
medium
38164Mandriva Linux Security Advisory : ghostscript (MDVSA-2009:095)NessusMandriva Local Security Checks
high
37438Ubuntu 6.06 LTS / 8.04 LTS / 8.10 : ghostscript, gs-esp, gs-gpl vulnerabilities (USN-757-1)NessusUbuntu Local Security Checks
high
37055Fedora 10 : ghostscript-8.63-6.fc10 (2009-3709)NessusFedora Local Security Checks
high
36166Fedora 9 : ghostscript-8.63-3.fc9 (2009-3710)NessusFedora Local Security Checks
high
36160RHEL 5 : ghostscript (RHSA-2009:0421)NessusRed Hat Local Security Checks
high