CVE-2008-4915

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The CPU hardware emulation in VMware Workstation 6.0.5 and earlier and 5.5.8 and earlier; Player 2.0.x through 2.0.5 and 1.0.x through 1.0.8; ACE 2.0.x through 2.0.5 and earlier, and 1.0.x through 1.0.7; Server 1.0.x through 1.0.7; ESX 2.5.4 through 3.5; and ESXi 3.5, when running 32-bit and 64-bit guest operating systems, does not properly handle the Trap flag, which allows authenticated guest OS users to gain privileges on the guest OS.

References

http://lists.vmware.com/pipermail/security-announce/2008/000042.html

http://secunia.com/advisories/32612

http://secunia.com/advisories/32624

http://security.gentoo.org/glsa/glsa-201209-25.xml

http://www.securityfocus.com/archive/1/498138/100/0/threaded

http://www.securityfocus.com/bid/32168

http://www.securitytracker.com/id?1021154

http://www.vmware.com/security/advisories/VMSA-2008-0018.html

http://www.vupen.com/english/advisories/2008/3052

https://exchange.xforce.ibmcloud.com/vulnerabilities/46415

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6309

Details

Source: MITRE

Published: 2008-11-10

Updated: 2018-11-02

Type: CWE-264

Risk Information

CVSS v2

Base Score: 6.9

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.4

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:vmware:ace:*:*:*:*:*:*:*:* versions from 1.0 to 1.0.7 (inclusive)

cpe:2.3:a:vmware:ace:*:*:*:*:*:*:*:* versions from 2.0 to 2.0.5 (inclusive)

cpe:2.3:a:vmware:esx:*:*:*:*:*:*:*:* versions from 2.5.4 to 3.5 (inclusive)

cpe:2.3:a:vmware:esxi:3.5:*:*:*:*:*:*:*

cpe:2.3:a:vmware:player:*:*:*:*:*:*:*:* versions from 1.0.0 to 1.0.8 (inclusive)

cpe:2.3:a:vmware:player:*:*:*:*:*:*:*:* versions from 2.0 to 2.0.5 (inclusive)

cpe:2.3:a:vmware:server:*:*:*:*:*:*:*:* versions from 1.0 to 1.0.7 (inclusive)

cpe:2.3:a:vmware:workstation:*:*:*:*:*:*:*:* versions from 5.5 to 5.5.8 (inclusive)

cpe:2.3:a:vmware:workstation:*:*:*:*:*:*:*:* versions from 6.0 to 6.0.5 (inclusive)

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
62383GLSA-201209-25 : VMware Player, Server, Workstation: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
40385VMSA-2008-0018 : VMware Hosted products and patches for ESX and ESXi resolve two security issuesNessusVMware ESX Local Security Checks
high
34818VMware Products Multiple Vulnerabilities (VMSA-2008-0018/VMSA-2008-0019)NessusWindows
medium