CVE-2008-4063

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple unspecified vulnerabilities in Mozilla Firefox 3.x before 3.0.2 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors related to the layout engine and (1) a zero value of the "this" variable in the nsContentList::Item function; (2) interaction of the indic IME extension, a Hindi language selection, and the "g" character; and (3) interaction of the nsFrameList::SortByContentOrder function with a certain insufficient protection of inline frames.

References

http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00005.html

http://secunia.com/advisories/31987

http://secunia.com/advisories/32011

http://secunia.com/advisories/32012

http://secunia.com/advisories/32025

http://secunia.com/advisories/32044

http://secunia.com/advisories/32082

http://secunia.com/advisories/32089

http://secunia.com/advisories/32095

http://secunia.com/advisories/32096

http://secunia.com/advisories/32196

http://secunia.com/advisories/34501

http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.379422

http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.412123

http://sunsolve.sun.com/search/document.do?assetkey=1-26-256408-1

http://www.mozilla.org/security/announce/2008/mfsa2008-42.html

http://www.redhat.com/support/errata/RHSA-2008-0879.html

http://www.securityfocus.com/bid/31346

http://www.securitytracker.com/id?1020916

http://www.ubuntu.com/usn/usn-645-1

http://www.ubuntu.com/usn/usn-645-2

http://www.ubuntu.com/usn/usn-647-1

http://www.vupen.com/english/advisories/2008/2661

http://www.vupen.com/english/advisories/2009/0977

https://bugzilla.mozilla.org/show_bug.cgi?id=413048

https://bugzilla.mozilla.org/show_bug.cgi?id=433758

https://bugzilla.mozilla.org/show_bug.cgi?id=444452

https://exchange.xforce.ibmcloud.com/vulnerabilities/45354

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11151

https://www.redhat.com/archives/fedora-package-announce/2008-September/msg01335.html

Details

Source: MITRE

Published: 2008-09-24

Updated: 2017-09-29

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Tenable Plugins

View all (35 total)

IDNameProductFamilySeverity
67744Oracle Linux 5 : firefox (ELSA-2008-0879)NessusOracle Linux Local Security Checks
critical
65110Ubuntu 6.06 LTS : firefox vulnerabilities (USN-645-2)NessusUbuntu Local Security Checks
critical
63402GLSA-201301-01 : Mozilla Products: Multiple vulnerabilities (BEAST)NessusGentoo Local Security Checks
critical
60475Scientific Linux Security Update : firefox on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
critical
43709CentOS 4 / 5 : firefox (CESA-2008:0879)NessusCentOS Local Security Checks
critical
40130openSUSE Security Update : seamonkey (seamonkey-238)NessusSuSE Local Security Checks
critical
40074openSUSE Security Update : mozilla-xulrunner190 (mozilla-xulrunner190-234)NessusSuSE Local Security Checks
critical
40071openSUSE Security Update : mozilla-xulrunner181 (mozilla-xulrunner181-237)NessusSuSE Local Security Checks
critical
39893openSUSE Security Update : MozillaThunderbird (MozillaThunderbird-236)NessusSuSE Local Security Checks
critical
39883openSUSE Security Update : MozillaFirefox (MozillaFirefox-233)NessusSuSE Local Security Checks
critical
38073Ubuntu 8.04 LTS : firefox-3.0, xulrunner-1.9 regression (USN-645-3)NessusUbuntu Local Security Checks
critical
37910Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : mozilla-thunderbird, thunderbird vulnerabilities (USN-647-1)NessusUbuntu Local Security Checks
critical
36243Ubuntu 7.04 / 7.10 / 8.04 LTS : firefox, firefox-3.0, xulrunner-1.9 vulnerabilities (USN-645-1)NessusUbuntu Local Security Checks
critical
34367openSUSE 10 Security Update : mozilla-xulrunner181 (mozilla-xulrunner181-5656)NessusSuSE Local Security Checks
critical
34366SuSE 10 Security Update : Mozilla (ZYPP Patch Number 5654)NessusSuSE Local Security Checks
critical
34360openSUSE 10 Security Update : seamonkey (seamonkey-5657)NessusSuSE Local Security Checks
critical
34345openSUSE 10 Security Update : MozillaThunderbird (MozillaThunderbird-5655)NessusSuSE Local Security Checks
critical
34319SuSE 10 Security Update : MozillaFirefox (ZYPP Patch Number 5644)NessusSuSE Local Security Checks
critical
34318openSUSE 10 Security Update : MozillaFirefox (MozillaFirefox-5640)NessusSuSE Local Security Checks
critical
34308Fedora 9 : Miro-1.2.4-3.fc9 / blam-1.8.5-2.fc9 / cairo-dock-1.6.2.3-1.fc9.1 / chmsee-1.0.1-5.fc9 / etc (2008-8425)NessusFedora Local Security Checks
critical
34300Slackware 10.2 / 11.0 / 12.0 / 12.1 / current : mozilla-thunderbird (SSA:2008-270-01)NessusSlackware Local Security Checks
critical
4696Mozilla Thunderbird < 2.0.0.17 Multiple VulnerabilitiesNessus Network MonitorSMTP Clients
medium
34296Slackware 11.0 / 12.0 / 12.1 / current : seamonkey (SSA:2008-269-02)NessusSlackware Local Security Checks
critical
34294Mozilla Thunderbird < 2.0.0.17 Multiple VulnerabilitiesNessusWindows
high
4693SeaMonkey < 1.1.12 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
4692Mozilla Firefox < 2.0.0.17 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
4691Mozilla Firefox < 3.0.2 Multiple Vulnerabilities Nessus Network MonitorWeb Clients
medium
34274RHEL 4 / 5 : firefox (RHSA-2008:0879)NessusRed Hat Local Security Checks
critical
34270FreeBSD : mozilla -- multiple vulnerabilities (2273879e-8a2f-11dd-a6fe-0030843d3802)NessusFreeBSD Local Security Checks
critical
34269SeaMonkey < 1.1.12 Multiple VulnerabilitiesNessusWindows
high
34268Firefox < 2.0.0.17 Multiple VulnerabilitiesNessusWindows
high
34267Firefox 3.0.x < 3.0.2 Multiple VulnerabilitiesNessusWindows
high
801289Mozilla Thunderbird < 2.0.0.17 Multiple VulnerabilitiesLog Correlation EngineSMTP Clients
high
800877SeaMonkey < 1.1.12 Multiple VulnerabilitiesLog Correlation EngineWeb Clients
high
800756Firefox < 3.0.2 Multiple Vulnerabilities Log Correlation EngineWeb Clients
high