CVE-2008-3632

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Use-after-free vulnerability in WebKit in Apple iPod touch 1.1 through 2.0.2, and iPhone 1.0 through 2.0.2, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a web page with crafted Cascading Style Sheets (CSS) import statements.

References

http://lists.apple.com/archives/security-announce//2008/Sep/msg00003.html

http://lists.apple.com/archives/security-announce//2008/Sep/msg00004.html

http://lists.apple.com/archives/security-announce/2009/jun/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2008-09/msg00005.html

http://secunia.com/advisories/31823

http://secunia.com/advisories/31900

http://secunia.com/advisories/32099

http://secunia.com/advisories/32860

http://secunia.com/advisories/35379

http://support.apple.com/kb/HT3026

http://support.apple.com/kb/HT3129

http://support.apple.com/kb/HT3613

http://www.securityfocus.com/bid/31092

http://www.securitytracker.com/id?1020847

http://www.ubuntu.com/usn/USN-676-1

http://www.vupen.com/english/advisories/2008/2525

http://www.vupen.com/english/advisories/2008/2558

http://www.vupen.com/english/advisories/2009/1522

Details

Source: MITRE

Published: 2008-09-11

Updated: 2012-10-31

Type: CWE-399

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
40021openSUSE Security Update : libQtWebKit-devel (libQtWebKit-devel-216)NessusSuSE Local Security Checks
high
39903openSUSE Security Update : WebKitGtk (WebKitGtk-212)NessusSuSE Local Security Checks
high
39339Safari < 4.0 Multiple VulnerabilitiesNessusWindows
high
39338Mac OS X : Apple Safari < 4.0NessusMacOS X Local Security Checks
high
37177Ubuntu 8.10 : webkit vulnerability (USN-676-1)NessusUbuntu Local Security Checks
high