CVE-2008-3272

LOW

Description

The snd_seq_oss_synth_make_info function in sound/core/seq/oss/seq_oss_synth.c in the sound subsystem in the Linux kernel before 2.6.27-rc2 does not verify that the device number is within the range defined by max_synthdev before returning certain data to the caller, which allows local users to obtain sensitive information.

References

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=82e68f7ffec3800425f2391c8c86277606860442

http://kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.27-rc2

http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00000.html

http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00001.html

http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00003.html

http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00008.html

http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00001.html

http://rhn.redhat.com/errata/RHSA-2008-0972.html

http://secunia.com/advisories/31366

http://secunia.com/advisories/31551

http://secunia.com/advisories/31614

http://secunia.com/advisories/31836

http://secunia.com/advisories/31881

http://secunia.com/advisories/32023

http://secunia.com/advisories/32103

http://secunia.com/advisories/32104

http://secunia.com/advisories/32190

http://secunia.com/advisories/32370

http://secunia.com/advisories/32759

http://secunia.com/advisories/32799

http://www.debian.org/security/2008/dsa-1630

http://www.debian.org/security/2008/dsa-1636

http://www.mandriva.com/security/advisories?name=MDVSA-2008:220

http://www.redhat.com/support/errata/RHSA-2008-0857.html

http://www.redhat.com/support/errata/RHSA-2008-0885.html

http://www.securityfocus.com/bid/30559

http://www.securitytracker.com/id?1020636

http://www.vupen.com/english/advisories/2008/2307

https://exchange.xforce.ibmcloud.com/vulnerabilities/44225

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11182

https://usn.ubuntu.com/637-1/

Details

Source: MITRE

Published: 2008-08-08

Updated: 2020-07-31

Type: CWE-200

Risk Information

CVSS v2.0

Base Score: 2.1

Vector: AV:L/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 3.9

Severity: LOW

Tenable Plugins

View all (21 total)

IDNameProductFamilySeverity
79448OracleVM 2.1 : kernel (OVMSA-2008-2006)NessusOracleVM Local Security Checks
high
67762Oracle Linux 4 : kernel (ELSA-2008-0972)NessusOracle Linux Local Security Checks
medium
67747Oracle Linux 5 : kernel (ELSA-2008-0885)NessusOracle Linux Local Security Checks
high
60497Scientific Linux Security Update : kernel on SL4.x i386/x86_64NessusScientific Linux Local Security Checks
medium
60477Scientific Linux Security Update : kernel on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
59131SuSE 10 Security Update : Linux kernel (ZYPP Patch Number 5608)NessusSuSE Local Security Checks
critical
59130SuSE 10 Security Update : Linux kernel (ZYPP Patch Number 5605)NessusSuSE Local Security Checks
critical
43710CentOS 5 : kernel (CESA-2008:0885)NessusCentOS Local Security Checks
high
41534SuSE 10 Security Update : Linux Kernel (x86) (ZYPP Patch Number 5565)NessusSuSE Local Security Checks
critical
40009openSUSE Security Update : kernel (kernel-171)NessusSuSE Local Security Checks
critical
37341CentOS 4 : kernel (CESA-2008:0972)NessusCentOS Local Security Checks
medium
34841RHEL 4 : kernel (RHSA-2008:0972)NessusRed Hat Local Security Checks
medium
34755openSUSE 10 Security Update : kernel (kernel-5751)NessusSuSE Local Security Checks
critical
34457openSUSE 10 Security Update : kernel (kernel-5700)NessusSuSE Local Security Checks
critical
34331SuSE 10 Security Update : the Linux Kernel (x86) (ZYPP Patch Number 5566)NessusSuSE Local Security Checks
critical
34288RHEL 5 : kernel (RHSA-2008:0885)NessusRed Hat Local Security Checks
high
34171Debian DSA-1636-1 : linux-2.6.24 - denial of service/information leakNessusDebian Local Security Checks
high
34048Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : linux, linux-source-2.6.15/20/22 vulnerabilities (USN-637-1)NessusUbuntu Local Security Checks
high
34032Debian DSA-1630-1 : linux-2.6 - denial of service/information leakNessusDebian Local Security Checks
high
801459CentOS RHSA-2008-0972 Security CheckLog Correlation EngineGeneric
high
801457CentOS RHSA-2008-0885 Security CheckLog Correlation EngineGeneric
high