CVE-2008-0628

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The XML parsing code in Sun Java Runtime Environment JDK and JRE 6 Update 3 and earlier processes external entity references even when the "external general entities" property is false, which allows remote attackers to conduct XML external entity (XXE) attacks and cause a denial of service or access restricted resources.

References

http://dev2dev.bea.com/pub/advisory/277

http://scary.beasts.org/security/CESA-2007-002.html

http://secunia.com/advisories/28746

http://secunia.com/advisories/29841

http://secunia.com/advisories/29858

http://secunia.com/advisories/30780

http://security.gentoo.org/glsa/glsa-200804-28.xml

http://securityreason.com/securityalert/3621

http://sunsolve.sun.com/search/document.do?assetkey=1-66-231246-1

http://www.gentoo.org/security/en/glsa/glsa-200804-20.xml

http://www.gentoo.org/security/en/glsa/glsa-200806-11.xml

http://www.redhat.com/support/errata/RHSA-2008-0245.html

http://www.securityfocus.com/archive/1/487434/100/0/threaded

http://www.securityfocus.com/bid/27553

http://www.securitytracker.com/id?1019292

http://www.vupen.com/english/advisories/2008/0371

http://www.vupen.com/english/advisories/2008/1252

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9847

Details

Source: MITRE

Published: 2008-02-06

Updated: 2018-10-15

Type: CWE-264

Risk Information

CVSS v2

Base Score: 7.8

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:C

Impact Score: 7.8

Exploitability Score: 8.6

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:sun:jdk:1.6:*:*:*:*:*:*:*

cpe:2.3:a:sun:jre:*:update3:*:*:*:*:*:* versions up to 1.6.0 (inclusive)

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
64825Sun Java JRE External XML Entities Restriction Bypass (231246) (Unix)NessusMisc.
high
63852RHEL 5 : java-1.6.0-bea (RHSA-2008:0245)NessusRed Hat Local Security Checks
high
32013GLSA-200804-20 : Sun JDK/JRE: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
30149Sun Java JRE External XML Entities Restriction Bypass (231246)NessusWindows
medium