CVE-2008-0122

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Off-by-one error in the inet_network function in libbind in ISC BIND 9.4.2 and earlier, as used in libc in FreeBSD 6.2 through 7.0-PRERELEASE, allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted input that triggers memory corruption.

References

http://lists.opensuse.org/opensuse-security-announce/2008-03/msg00004.html

http://secunia.com/advisories/28367

http://secunia.com/advisories/28429

http://secunia.com/advisories/28487

http://secunia.com/advisories/28579

http://secunia.com/advisories/29161

http://secunia.com/advisories/29323

http://secunia.com/advisories/30313

http://secunia.com/advisories/30538

http://secunia.com/advisories/30718

http://security.freebsd.org/advisories/FreeBSD-SA-08:02.libc.asc

http://sunsolve.sun.com/search/document.do?assetkey=1-26-238493-1

http://support.avaya.com/elmodocs2/security/ASA-2008-244.htm

http://www.isc.org/index.pl?/sw/bind/bind-security.php

http://www.kb.cert.org/vuls/id/203611

http://www.redhat.com/support/errata/RHSA-2008-0300.html

http://www.securityfocus.com/archive/1/487000/100/0/threaded

http://www.securityfocus.com/bid/27283

http://www.securitytracker.com/id?1019189

http://www.vupen.com/english/advisories/2008/0193

http://www.vupen.com/english/advisories/2008/0703

http://www.vupen.com/english/advisories/2008/1743/references

http://www14.software.ibm.com/webapp/set2/subscriptions/ijhifoeblist?mode=7&heading=AIX61&path=/200802/SECURITY/20080227/datafile123640&label=AIX%20libc%20inet_network%20buffer%20overflow

http://www14.software.ibm.com/webapp/set2/subscriptions/pqvcmjd?mode=18&ID=4167

https://bugzilla.redhat.com/show_bug.cgi?id=429149

https://exchange.xforce.ibmcloud.com/vulnerabilities/39670

https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04952488

https://issues.rpath.com/browse/RPL-2169

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10190

https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00781.html

https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00782.html

Details

Source: MITRE

Published: 2008-01-16

Updated: 2019-08-01

Type: CWE-189

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

AND

OR

cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*

OR

cpe:2.3:o:freebsd:freebsd:6.2:-:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p1:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p10:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p11:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p12:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p4:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p5:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p6:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p7:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p8:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:p9:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:rc1:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.2:rc2:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:-:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p1:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p10:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p11:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p12:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p13:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p14:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p15:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p2:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p3:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p4:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p5:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p6:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p7:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p8:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:p9:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.3:rc2:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:-:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p1:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p10:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p11:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p2:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p3:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p4:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p5:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p6:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p7:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p8:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:6.4:p9:*:*:*:*:*:*

Tenable Plugins

View all (18 total)

IDNameProductFamilySeverity
147379NewStart CGSL CORE 5.04 / MAIN 5.04 : bind Multiple Vulnerabilities (NS-SA-2021-0017)NessusNewStart CGSL Local Security Checks
critical
137170OracleVM 3.3 / 3.4 : bind (OVMSA-2020-0021)NessusOracleVM Local Security Checks
high
107478Solaris 10 (sparc) : 136892-01NessusSolaris Local Security Checks
critical
99569OracleVM 3.3 / 3.4 : bind (OVMSA-2017-0066)NessusOracleVM Local Security Checks
high
60402Scientific Linux Security Update : bind on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
critical
41191SuSE9 Security Update : bind (YOU Patch Number 12060)NessusSuSE Local Security Checks
critical
33470Fedora 8 : bind-9.5.0-28.P1.fc8 (2008-6281)NessusFedora Local Security Checks
critical
33212Solaris 8 (x86) : 111328-05NessusSolaris Local Security Checks
critical
33211Solaris 8 (sparc) : 111327-06NessusSolaris Local Security Checks
critical
33205Solaris 10 (sparc) : 136892-01NessusSolaris Local Security Checks
critical
32424RHEL 5 : bind (RHSA-2008:0300)NessusRed Hat Local Security Checks
critical
31450SuSE 10 Security Update : bind (ZYPP Patch Number 4932)NessusSuSE Local Security Checks
critical
31449openSUSE 10 Security Update : bind (bind-4931)NessusSuSE Local Security Checks
critical
30081Fedora 7 : bind-9.4.2-3.fc7 (2008-0904)NessusFedora Local Security Checks
critical
30080Fedora 8 : bind-9.5.0-23.b1.fc8 (2008-0903)NessusFedora Local Security Checks
critical
13429Solaris 8 (x86) : 109327-24NessusSolaris Local Security Checks
critical
13321Solaris 8 (sparc) : 109326-24NessusSolaris Local Security Checks
critical
13315Solaris 8 (sparc) : 109152-03NessusSolaris Local Security Checks
critical