CVE-2007-6725

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The CCITTFax decoding filter in Ghostscript 8.60, 8.61, and possibly other versions, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PDF file that triggers a buffer underflow in the cf_decode_2d function.

References

http://lists.opensuse.org/opensuse-security-announce/2009-06/msg00003.html

http://secunia.com/advisories/34726

http://secunia.com/advisories/34729

http://secunia.com/advisories/34732

http://secunia.com/advisories/35416

http://secunia.com/advisories/35559

http://secunia.com/advisories/35569

http://sunsolve.sun.com/search/document.do?assetkey=1-26-262288-1

http://support.avaya.com/elmodocs2/security/ASA-2009-155.htm

http://wiki.rpath.com/Advisories:rPSA-2009-0060

http://www.mail-archive.com/[email protected]/msg11830.html

http://www.mandriva.com/security/advisories?name=MDVSA-2009:095

http://www.mandriva.com/security/advisories?name=MDVSA-2009:096

http://www.openwall.com/lists/oss-security/2009/04/01/10

http://www.redhat.com/support/errata/RHSA-2009-0420.html

http://www.redhat.com/support/errata/RHSA-2009-0421.html

http://www.securityfocus.com/archive/1/502757/100/0/threaded

http://www.securityfocus.com/bid/34337

http://www.vupen.com/english/advisories/2009/1708

https://bugzilla.redhat.com/show_bug.cgi?id=229174

https://bugzilla.redhat.com/show_bug.cgi?id=493442

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9507

https://usn.ubuntu.com/757-1/

Details

Source: MITRE

Published: 2009-04-08

Updated: 2018-10-15

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
67841Oracle Linux 5 : ghostscript (ELSA-2009-0421)NessusOracle Linux Local Security Checks
high
67840Oracle Linux 3 / 4 : ghostscript (ELSA-2009-0420)NessusOracle Linux Local Security Checks
high
60565Scientific Linux Security Update : ghostscript on SL3.x, SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
48223Debian DSA-2080-1 : ghostscript - several vulnerabilitiesNessusDebian Local Security Checks
critical
43741CentOS 5 : ghostscript (CESA-2009:0421)NessusCentOS Local Security Checks
high
42997Mandriva Linux Security Advisory : ghostscript (MDVSA-2009:311)NessusMandriva Local Security Checks
critical
41513SuSE 10 Security Update : GhostScript (ZYPP Patch Number 6245)NessusSuSE Local Security Checks
high
41396SuSE 11 Security Update : GhostScript (SAT Patch Number 876)NessusSuSE Local Security Checks
high
41300SuSE9 Security Update : GhostScript (YOU Patch Number 12417)NessusSuSE Local Security Checks
high
40220openSUSE Security Update : ghostscript-devel (ghostscript-devel-877)NessusSuSE Local Security Checks
high
39968openSUSE Security Update : ghostscript-devel (ghostscript-devel-877)NessusSuSE Local Security Checks
high
38807openSUSE 10 Security Update : ghostscript-devel (ghostscript-devel-6246)NessusSuSE Local Security Checks
high
38164Mandriva Linux Security Advisory : ghostscript (MDVSA-2009:095)NessusMandriva Local Security Checks
high
37438Ubuntu 6.06 LTS / 8.04 LTS / 8.10 : ghostscript, gs-esp, gs-gpl vulnerabilities (USN-757-1)NessusUbuntu Local Security Checks
high
36160RHEL 5 : ghostscript (RHSA-2009:0421)NessusRed Hat Local Security Checks
high
36159RHEL 3 / 4 : ghostscript (RHSA-2009:0420)NessusRed Hat Local Security Checks
high
36155CentOS 3 / 4 : ghostscript (CESA-2009:0420)NessusCentOS Local Security Checks
high