CVE-2007-6170

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

SQL injection vulnerability in the Call Detail Record Postgres logging engine (cdr_pgsql) in Asterisk 1.4.x before 1.4.15, 1.2.x before 1.2.25, B.x before B.2.3.4, and C.x before C.1.0-beta6 allows remote authenticated users to execute arbitrary SQL commands via (1) ANI and (2) DNIS arguments.

References

http://downloads.digium.com/pub/security/AST-2007-026.html

http://lists.opensuse.org/opensuse-security-announce/2008-03/msg00001.html

http://secunia.com/advisories/27827

http://secunia.com/advisories/27892

http://secunia.com/advisories/29242

http://secunia.com/advisories/29782

http://security.gentoo.org/glsa/glsa-200804-13.xml

http://securitytracker.com/id?1019020

http://www.debian.org/security/2007/dsa-1417

http://www.securityfocus.com/archive/1/484388/100/0/threaded

http://www.securityfocus.com/bid/26647

http://www.vupen.com/english/advisories/2007/4056

https://exchange.xforce.ibmcloud.com/vulnerabilities/38765

Details

Source: MITRE

Published: 2007-11-30

Updated: 2018-10-26

Type: CWE-89

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
31960GLSA-200804-13 : Asterisk: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
31390openSUSE 10 Security Update : asterisk (asterisk-5062)NessusSuSE Local Security Checks
medium
29191Debian DSA-1417-1 : asterisk - missing input sanitisingNessusDebian Local Security Checks
medium