CVE-2007-5707

HIGH

Description

OpenLDAP before 2.3.39 allows remote attackers to cause a denial of service (slapd crash) via an LDAP request with a malformed objectClasses attribute. NOTE: this has been reported as a double free, but the reports are inconsistent.

References

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440632

http://lists.apple.com/archives/security-announce/2009/Nov/msg00000.html

http://secunia.com/advisories/27424

http://secunia.com/advisories/27587

http://secunia.com/advisories/27596

http://secunia.com/advisories/27683

http://secunia.com/advisories/27756

http://secunia.com/advisories/27868

http://secunia.com/advisories/29461

http://secunia.com/advisories/29682

http://security.gentoo.org/glsa/glsa-200803-28.xml

http://support.apple.com/kb/HT3937

http://www.debian.org/security/2008/dsa-1541

http://www.mandriva.com/security/advisories?name=MDKSA-2007:215

http://www.novell.com/linux/security/advisories/2007_24_sr.html

http://www.openldap.org/its/index.cgi/Software%20Bugs?id=5119

http://www.openldap.org/lists/openldap-announce/200710/msg00001.html

http://www.redhat.com/archives/fedora-package-announce/2007-November/msg00460.html

http://www.redhat.com/support/errata/RHSA-2007-1037.html

http://www.redhat.com/support/errata/RHSA-2007-1038.html

http://www.securityfocus.com/bid/26245

http://www.securitytracker.com/id?1018924

http://www.ubuntu.com/usn/usn-551-1

http://www.vupen.com/english/advisories/2007/3645

http://www.vupen.com/english/advisories/2009/3184

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10183

Details

Source: MITRE

Published: 2007-10-30

Updated: 2017-09-29

Type: CWE-399

Risk Information

CVSS v2.0

Base Score: 7.1

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 8.6

Severity: HIGH